Forum: Ruby annoyance with gems and zlib

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Vincent D. (Guest)
on 2009-04-03 19:29
Hi ... i've been trying to get rails up and running on my system. I run
OS X leopard. updated ruby to 1.8.7. Installed ruby 1.9 with a suffix
following this guide (http://ruby.tie-rack.org/28/installing-19/)

So I checked what rails version I had ... turns out to be 1.2.6 *iiiiik*

Quickly typed the following:

mbp:~ spobo$ gem update rails -v

And got this awesome result.

Updating installed gems
GET 302 Found: http://gems.rubyforge.org/latest_specs.4.8.gz
GET 200 OK:
http://guide.opendns.com/?url=gems.rubyforge.org%2...
ERROR:  While executing gem ... (Zlib::GzipFile::Error)
    not in gzip format
mbp:~ spobo$

so ... anyone have any clues? I'm sort of really stumped as to what goes
where when you compile programs like ruby as to what goes where and how
do you tweak/uninstall it when necessary.

ps:

mbp:~ spobo$ sudo gem update --system
Updating RubyGems
ERROR:  While executing gem ... (Zlib::GzipFile::Error)
    not in gzip format

ps2: yes, I know I'm not using ruby 1.9 when I do the simple gem command
and no, gem19 install rails and gem19 update --system do the same.
Ara H. (Guest)
on 2009-04-03 19:40
(Received via mailing list)
On Apr 3, 2009, at 9:28 AM, Vincent Ds wrote:

> nd got this awesome result.
>
> Updating installed gems
> GET 302 Found: http://gems.rubyforge.org/latest_specs.4.8.gz
> GET 200 OK:
> http://guide.opendns.com/?url=gems.rubyforge.org%2...


did you even try clicking the above link?


you are having dns issues.  either that, or gems.rubyforge.org was
down when you ran that command.  first step is always to read the
error messages!  ;-)

regards.

>
> ERROR:  While executing gem ... (Zlib::GzipFile::Error)
>    not in gzip format
> mbp:~ spobo$

a @ http://codeforpeople.com/
Vincent D. (Guest)
on 2009-04-03 19:52
Ara Howard wrote:
> On Apr 3, 2009, at 9:28 AM, Vincent Ds wrote:
>
>> nd got this awesome result.
>>
>> Updating installed gems
>> GET 302 Found: http://gems.rubyforge.org/latest_specs.4.8.gz
>> GET 200 OK:
>> http://guide.opendns.com/?url=gems.rubyforge.org%2...
>
>
> did you even try clicking the above link?

Well ... to tell the truth I only got that reply once. The 90 other
times everything just said not in gzip format without anything else. I
was hoping it was more of a quick fix and a known issue. I'll try
turning off opendns and see what happens then.

>
>
> you are having dns issues.  either that, or gems.rubyforge.org was
> down when you ran that command.  first step is always to read the
> error messages!  ;-)
>
> regards.
>
>>
>> ERROR:  While executing gem ... (Zlib::GzipFile::Error)
>>    not in gzip format
>> mbp:~ spobo$
>
> a @ http://codeforpeople.com/
Eric H. (Guest)
on 2009-04-04 00:37
(Received via mailing list)
On Apr 3, 2009, at 08:52, Vincent Ds wrote:
>> did you even try clicking the above link?
>
> Well ... to tell the truth I only got that reply once. The 90 other
> times everything just said not in gzip format without anything else. I
> was hoping it was more of a quick fix and a known issue. I'll try
> turning off opendns and see what happens then.

Did you try fetching either URL (using wget or curl or telnet)?

It seems that opendns breaks the internet on purpose.  I would avoid
it at all cost.
Vincent D. (Guest)
on 2009-04-04 00:53
Eric H. wrote:
> On Apr 3, 2009, at 08:52, Vincent Ds wrote:
>>> did you even try clicking the above link?
>>
>> Well ... to tell the truth I only got that reply once. The 90 other
>> times everything just said not in gzip format without anything else. I
>> was hoping it was more of a quick fix and a known issue. I'll try
>> turning off opendns and see what happens then.
>
> Did you try fetching either URL (using wget or curl or telnet)?
>
> It seems that opendns breaks the internet on purpose.  I would avoid
> it at all cost.

I completely agree. Turned off opendns and everything started working
magically. Who knew ... perhaps the guys running opendns are Java
fanboys? Also, rails was using a different version of ruby which led to
some incompatibilities between rubygems and rails. Everything is fixed
now and running smoothly with phusion passenger ... brilliant :p Off to
do some conding!
David M. (Guest)
on 2009-04-04 03:19
(Received via mailing list)
On Friday 03 April 2009 15:53:27 Vincent Ds wrote:
> Eric H. wrote:
> > It seems that opendns breaks the internet on purpose.  I would avoid
> > it at all cost.
>
> I completely agree. Turned off opendns and everything started working
> magically. Who knew ... perhaps the guys running opendns are Java
> fanboys?

Nah, they just hate the Internet. Maybe they're Flash fanbois?

However, it is possible to register an IP address to not use this
"feature":

<http://www.labnol.org/internet/stop-opendns-from-r...
typos/4112/>

Not great, but it works, if your ISP-provided DNS is really bad enough
that
you need OpenDNS. If not, easier to just turn it off.
This topic is locked and can not be replied to.