Forum: Typo feedback.rb: unexpected tASSOC

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Tobias W. (Guest)
on 2009-03-26 14:44
(Received via mailing list)
Hi guys,

you might want to check lines 146 and 155 in feedback.rb:

Timeout::Error => e

This seems to by incorrect syntax. At least it keeps my Mongrel from
starting up Typo:

Exiting
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:382:in
`load_without_new_constant_marking':
/home/tweisser/workspace/typo/typo/app/models/feedback.rb:146: syntax
error,
unexpected tASSOC (SyntaxError)
      Timeout::Error => e
                       ^
/home/tweisser/workspace/typo/typo/app/models/feedback.rb:155: syntax
error,
unexpected tASSOC
      Timeout::Error => e
                       ^
        from
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:382:in
`load_file'
        from
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:521:in
`new_constants_in'
        from
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:381:in
`load_file'
        from
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:256:in
`require_or_load'
        from
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:427:in
`load_missing_constant'
        from
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:77:in
`const_missing'
        from
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:89:in
`const_missing'
        from /home/tweisser/workspace/typo/typo/app/models/comment.rb:4
         ... 67 levels...
        from
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/commands/server.rb:49
        from
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
        from
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
        from script/server:3

cheers,

Tobias
de Villamil Frédéric (Guest)
on 2009-03-26 15:25
(Received via mailing list)
Hi,

I've seen this yesterday evening but was too tired to fix it.
It s done now.

Le 26 mars 09 à 13:36, Tobias Weisserth a écrit :

> /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/
>         from /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/
> `require_or_load'
> comment.rb:4
>
> Tobias
> _______________________________________________
> Typo-list mailing list
> removed_email_address@domain.invalid
> http://rubyforge.org/mailman/listinfo/typo-list

--
Frédéric de Villamil
"What's mine is mine. What's yours is still unsetteled" – Go player
proverb
removed_email_address@domain.invalid                        tel: +33 (0)6 62 19 
1337
http://t37.net                       Typo : http://typosphere.org
Tobias W. (Guest)
on 2009-03-26 15:41
(Received via mailing list)
Thanks!

2009/3/26 de Villamil Frédéric <removed_email_address@domain.invalid>
This topic is locked and can not be replied to.