Forum: GNU Radio libusrp not copied to /usr/lib directory

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Fabian (Guest)
on 2009-03-25 12:46
(Received via mailing list)
Hello!

I'm using GNURadio (from the svn repository) with OpenBTS and
everything worked fine.
Now I did this procedure:
sudo make uninstall
sudo make distclean
svn update
./bootstrap
./configure
make
make check
sudo make install

I got the trunk version 10680. Everything seemed to be okay.
Now I want to reinstall OpenBTS and an error occured that there isn't
"libusrp".

I checked it with
# locate libusrp.so
and I get:
/home/openbts/gnuradio/usrp/host/lib/legacy/.libs/libusrp.so
/home/openbts/gnuradio/usrp/host/lib/legacy/.libs/libusrp.so.0
/home/openbts/gnuradio/usrp/host/lib/legacy/.libs/libusrp.so.0.0.0

But I thought the files must be in
/usr/lib/ or
/usr/local/lib/
and I think OpenBTS will also try to search it in these library
directories.

Was there a change in the last few weeks? I checked the repository of
GNURadio, but I didn't find
that there was a change so the created libusrp-files won't be copied
to the library directory.

Could anyone help me?

- Fabian
Fabian (Guest)
on 2009-03-25 15:11
(Received via mailing list)
I reinstalled GNURadio two times and now I have the libusrp libraries.
Perhaps the problem lies elsewhere...

- Fabian

Am 25.03.2009 um 11:45 schrieb Fabian:
David B. (Guest)
on 2009-03-25 18:31
(Received via mailing list)
I was getting a report of exactly the same thing from someone else
last week.  He fixed it by creating a soft link.

-- David


On Mar 25, 2009, at 3:45 AM, Fabian wrote:

> make
> /home/openbts/gnuradio/usrp/host/lib/legacy/.libs/libusrp.so
> of GNURadio, but I didn't find
> removed_email_address@domain.invalid
> http://lists.gnu.org/mailman/listinfo/discuss-gnuradio


David A. Burgess
Kestrel Signal Processing, Inc.
Eric B. (Guest)
on 2009-03-25 19:42
(Received via mailing list)
On Wed, Mar 25, 2009 at 11:45:52AM +0100, Fabian wrote:
> make
> make check
> sudo make install

The way you've run configure, it will end up in either

  /usr/local/lib/libusrp.so

    or

  /usr/local/lib64/libusrp.so

Depending on your machine characteristics.

Eric
This topic is locked and can not be replied to.