Forum: RSpec Problems with gem rdoc rspec

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Andrew V. (Guest)
on 2009-03-24 01:30
(Received via mailing list)
My gems, e.g. rspec, gets installed in:

(Note the extra /gems/ subdirectory)

When I run "gem rdoc rspec" the output is empty and the Files section
has errors:

file not found -/Library/Ruby/Gems/1.8/rspec-1.2.2/rdoc/License.txt-
file not found -/Library/Ruby/Gems/1.8/rspec-1.2.2/rdoc/Manifest.txt-
file not found -/Library/Ruby/Gems/1.8/rspec-1.2.2/rdoc/examples/
file not found -/Library/Ruby/Gems/1.8/rspec-1.2.2/rdoc/TODO.txt-

(Those are the only files in there. Note the lack of /gems/

Do I need to add /gems/ to my GEM_PATH? I didn't think that's how it
works, and my other rubygems build their rdocs fine.

Or do I need to set a different path variable to set this up?
(GEM_HOME? I tried that and it didn't seem to help.)

Thanks for your help,
Andrew V.

My environment:

$ echo $GEM_PATH

$ more ~/.gemrc
verbose: true
update_sources: true
backtrace: false
bulk_threshold: 1000
benchmark: false
gem: --rdoc
rdoc:  --fmt ajax --charset utf8 --exclude .*generator.* --
exclude .*test.* --exclude .*spec.*
This topic is locked and can not be replied to.