Forum: GNU Radio problem in configure with trunk 10632

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Brett L. Trotter (Guest)
on 2009-03-17 23:19
(Received via mailing list)
checking for xdg-mime... true
checking for Python >= 2.5... yes
checking for Python Cheetah templates >= 2.0.0... yes
checking for Python lxml wrappers >= 2.0.0... yes
checking for Python gtk wrappers >= 2.10.0...

^C^C^C^C^C^C^C^C^C^C^C



can't control C either..

this has happened on an ubuntu intrepid box, and two FC10 boxes
independently.
Josh B. (Guest)
on 2009-03-17 23:34
(Received via mailing list)
what does python --version give you?

what happens when you run python -c "import gtk" in the same terminals?
Brett L. Trotter (Guest)
on 2009-03-18 00:03
(Received via mailing list)
Josh B. wrote:
> what does python --version give you?
>
> what happens when you run python -c "import gtk" in the same terminals?
ubuntu:
root@phenom2:~/gnuradio# uname -a
Linux phenom2 2.6.27-11-generic #1 SMP Thu Jan 29 19:28:32 UTC 2009
x86_64 GNU/Linux
root@phenom2:~/gnuradio# python --version
Python 2.5.2
root@phenom2:~/gnuradio# python -c "import gtk"
---- freezes as in configure

FC10 #1:
[root@phenom gnuradio]# python --version
Python 2.5.2
[root@phenom gnuradio]# python -c "import gtk"
---- same freeze

FC10 #2:
[root@evo2 gnuradio]# python --version
Python 2.5.2
[root@evo2 gnuradio]# python -c "import gtk"
---- same freeze
Josh B. (Guest)
on 2009-03-18 00:08
(Received via mailing list)
Thats really bad!

howabout

python -c "import pygtk; pygtk.require('2.0'); import gtk"
Brett L. Trotter (Guest)
on 2009-03-18 01:17
(Received via mailing list)
the same.

top doesn't show anything eating up CPU, at all.
Johnathan C. (Guest)
on 2009-03-18 01:30
(Received via mailing list)
On Tue, Mar 17, 2009 at 4:16 PM, Brett L. Trotter 
<removed_email_address@domain.invalid>
wrote:

> top doesn't show anything eating up CPU, at all.

Are you perhaps ssh'd in and have X forwarded over your network?

Johnathan
Brett L. Trotter (Guest)
on 2009-03-18 01:40
(Received via mailing list)
Usually for stuff like compiling and it has worked in the past (even a
few days ago).
You're correct, when I come on with VNC or console, it works fine.

Any idea what broke?
Johnathan C. (Guest)
on 2009-03-18 01:45
(Received via mailing list)
On Tue, 2009-03-17 at 18:39 -0500, Brett L. Trotter wrote:

> Usually for stuff like compiling and it has worked in the past (even a
> few days ago).

> You're correct, when I come on with VNC or console, it works fine.
>
> Any idea what broke?

No idea.  But I've seen this happen before, unrelated to GNU Radio.  Can
you try using ssh but with the -x option (lowercase, disables X11
forwarding.)

Johnathan
This topic is locked and can not be replied to.