Forum: Rails-ES rail 2.2.2 no instala en linux ubuntu

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Aprendiz_ror R. (Guest)
on 2009-03-16 14:29
buenos dias.

por si depronto les ha pasado intento instalar rails en linux ubunto
7.04 server y se queda instalando:

root@ubuntu:~# export http_proxy="http://172.20.49.51:80"
root@ubuntu:~# gem install rails
Bulk updating Gem source index for: http://gems.rubyforge.org/
Bulk updating Gem source index for: http://gems.rubyforge.org/

sera que hay que hacer algo diferente?

gracias por la ayuda.

saludos
Aprendiz_ror R. (Guest)
on 2009-03-16 14:54
uenos dias.

logre la instalacion siguiendo este instructivo.

http://railsforum.com/viewtopic.php?pid=16102

mil gracias
Aprendiz_ror R. (Guest)
on 2009-03-16 15:03
disculpen, sigue el problema.

a pesar de que instala cuando escribo rails -v me genera error:

root@ubuntu:~# rails -v
/usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/vendor.rb:5:
undefined method `gem' for main:Object (NoMethodError)
        from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in `requ
ire__'
        from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in `requ
ire'
        from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support.
rb:24
        from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in `requ
ire__'
        from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in `requ
ire'
        from
/usr/lib/ruby/gems/1.8/gems/activerecord-2.2.2/lib/active_record.rb
:25
        from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in `requ
Jose Rafael C. (Guest)
on 2009-03-18 02:50
Yo publiqué en tutorial en mi blog, puedes revisarlo en:
http://www.joserafael.com.ve/blog/index.php/2007/1...






Aprendiz_ror Ruby on rails wrote:
> disculpen, sigue el problema.
>
> a pesar de que instala cuando escribo rails -v me genera error:
>
> root@ubuntu:~# rails -v
> /usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/vendor.rb:5:
> undefined method `gem' for main:Object (NoMethodError)
>         from
> /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in `requ
> ire__'
>         from
> /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in `requ
> ire'
>         from
> /usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support.
> rb:24
>         from
> /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in `requ
> ire__'
>         from
> /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in `requ
> ire'
>         from
> /usr/lib/ruby/gems/1.8/gems/activerecord-2.2.2/lib/active_record.rb
> :25
>         from
> /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in `requ
Aprendiz_ror R. (Guest)
on 2009-03-18 15:11
Gracias Jose Rafael por tu respuesta esta muy bueno tu informacion, pero
ahora me genera el error siguiente, estoy por reinstalar todo, desde
linux para arriba.le dejo el error por si acaso, parece error de

root@ubuntu:~# sudo gem1.8 install mongrel
Building native extensions.  This could take a while...
ERROR:  Error installing mongrel:
        ERROR: Failed to build gem native extension.

/usr/bin/ruby1.8 extconf.rb install mongrel
checking for main() in -lc... no
creating Makefile

make
cc -I. -I. -I/usr/lib/ruby/1.8/i486-linux -I.  -fPIC
-fno-strict-aliasing -g -g
-O2  -fPIC  -c http11.c
cc -I. -I. -I/usr/lib/ruby/1.8/i486-linux -I.  -fPIC
-fno-strict-aliasing -g -g
-O2  -fPIC  -c http11_parser.c
cc -shared -o http11.so http11.o http11_parser.o -L"." -L"/usr/lib" -L.
-Wl,-Bsy
mbolic-functions -rdynamic -Wl,-export-dynamic    -lruby1.8  -lpthread
-ldl -lcr
ypt -lm   -lc
/usr/bin/ld: unrecognized option '-Bsymbolic-functions'
/usr/bin/ld: use the --help option for usage information
collect2: ld returned 1 exit status
make: *** [http11.so] Error 1


Gem files will remain installed in
/usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5 for
 inspection.
Results logged to
/usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/ext/http11/gem_make.
out
root@ubuntu:~#
Jorge Calás Lozano (Guest)
on 2009-03-18 15:34
(Received via mailing list)
sudo apt-get install ruby-dev
Aprendiz_ror R. (Guest)
on 2009-03-18 15:39
Jorge Calás Lozano wrote:
> sudo apt-get install ruby-dev

Gracias por tu ayuda. ya lo habia hecho y me genera lo siguiente:

root@ubuntu:~# sudo apt-get install ruby-dev
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Reading state information... Hecho
E: No se pudo encontrar el paquete ruby-dev

saludos
Luis felipe H. (Guest)
on 2009-03-18 15:42
(Received via mailing list)
Sería

sudo apt-get install ruby1.8-dev

2009/3/18 Jorge Calás Lozano <removed_email_address@domain.invalid>
Aprendiz_ror R. (Guest)
on 2009-03-18 16:12
Hola Luis Felipe.

que bueno saber  nuevamente de ti, pues habia perdido tu rastro.
regalame tu correo, el mio es removed_email_address@domain.invalid y ahora
tengo otro rol dentro del sena y necesito hablar contigo.

gracias por tu respuesta, pero tampoco me funciona. Me genera lo
siguiente:

root@ubuntu:~# sudo apt-get install ruby1.8-dev
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Reading state information... Hecho
ruby1.8-dev ya está en su versión más reciente.
0 actualizados, 0 se instalarán, 0 para eliminar y 235 no actualizados.
root@ubuntu:~#
Aprendiz_ror R. (Guest)
on 2009-03-20 02:37
Buenas, reinstale linux y el error era en el paquete sudo apt-get
install ruby1.8-dev

ya en la nueva instalacion cuando me fallo la instalada de mongrel,
corri este paquete y listo.

no se por que fallaba este paquete, si lo intentaba instalar me decia
que ya estaba y tampoco se dejaba desinstalar.

gracias por sus aportes
This topic is locked and can not be replied to.