Forum: Ruby on Rails gem install blackbook on centos error

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Jeba M. (Guest)
on 2009-03-13 11:07
Hello,
I'm trying to install the blackbook gem on my m/c with centos , but i
get the following error:
Building native extensions.  This could take a while...
ERROR:  Error installing blackbook:
        ERROR: Failed to build gem native extension.

/opt/ruby-enterprise-1.8.6-20090201/bin/ruby extconf.rb install
blackbook
checking for #include <libxml/parser.h>
... yes
checking for #include <libxslt/xslt.h>
... no
libxslt is missing.  try 'port install libxslt' or 'yum install libxslt'
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

Provided configuration options:
        --with-opt-dir
        --without-opt-dir
        --with-opt-include
        --without-opt-include=${opt-dir}/include
        --with-opt-lib
        --without-opt-lib=${opt-dir}/lib
        --with-make-prog
        --without-make-prog
        --srcdir=.
        --curdir
        --ruby=/opt/ruby-enterprise-1.8.6-20090201/bin/ruby
        --with-xml2-dir
        --without-xml2-dir
        --with-xml2-include
        --without-xml2-include=${xml2-dir}/include
        --with-xml2-lib
        --without-xml2-lib=${xml2-dir}/lib
        --with-xslt-dir
        --without-xslt-dir
        --with-xslt-include
        --without-xslt-include=${xslt-dir}/include
        --with-xslt-lib
        --without-xslt-lib=${xslt-dir}/lib


Gem files will remain installed in
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/nokogiri-1.2.1
for inspection.
Results logged to
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/nokogiri-1.2.1/ext/nokogiri/gem_make.out

Please can someone help me solve this....
Thank you....
Charles J. (Guest)
on 2009-03-13 15:06
(Received via mailing list)
On Fri, Mar 13, 2009 at 4:07 AM, Jeba M. <
removed_email_address@domain.invalid> wrote:

> checking for #include <libxml/parser.h>
> ... yes
> checking for #include <libxslt/xslt.h>
> ... no
> libxslt is missing.  try 'port install libxslt' or 'yum install libxslt'
> *** extconf.rb failed ***
> Could not create Makefile due to some reason, probably lack of
> necessary libraries and/or headers.  Check the mkmf.log file for more
> details.  You may need configuration options.


So, did you try what the error suggested? Did you do  'yum install
libxslt'
 ?

Cheers--

Charles
Jeba M. (Guest)
on 2009-03-13 15:11
Charles J. wrote:

> So, did you try what the error suggested? Did you do  'yum install
> libxslt'
>  ?
>Charles

Thanks for replying...
I dont have YUM installed on my m/c so I did..
up2date install libxslt

It worked fine and installed successfully.
But while doing
gem install blackbook
I get exactly the same error again...!!!   :(
Where am I going wrong???

Thank you.
Charles J. (Guest)
on 2009-03-13 15:24
(Received via mailing list)
On Fri, Mar 13, 2009 at 8:11 AM, Jeba M. <
removed_email_address@domain.invalid> wrote:

>
Exactly the same error message? (Sorry about asking that.)

Cheers--

Charles
Jeba M. (Guest)
on 2009-03-13 15:37
Charles J. wrote:
> On Fri, Mar 13, 2009 at 8:11 AM, Jeba M. <
> removed_email_address@domain.invalid> wrote:
>
>>
> Exactly the same error message? (Sorry about asking that.)
>
> Cheers--
>
> Charles

Yes..exactly the same error message....
And I don't have the privileges to install YUM on the m/c.
So can't even do that...
Frederick C. (Guest)
on 2009-03-13 17:31
(Received via mailing list)
On Mar 13, 1:37 pm, Jeba M. <removed_email_address@domain.invalid>
wrote:
> Yes..exactly the same error message....
> And I don't have the privileges to install YUM on the m/c.
> So can't even do that...

I know nothing about centos, but did you just install the libraries or
did you also install the associated development headers (they are
frequently split out into separate packages eg libfoo and libfoo-dev
or libfoo-devel)

Fred
Anjali C. (Guest)
on 2010-01-01 20:00
Jeba M. wrote:
> Charles J. wrote:
>> On Fri, Mar 13, 2009 at 8:11 AM, Jeba M. <
>> removed_email_address@domain.invalid> wrote:
>>
>>>
>> Exactly the same error message? (Sorry about asking that.)
>>
>> Cheers--
>>
>> Charles
>
> Yes..exactly the same error message....
> And I don't have the privileges to install YUM on the m/c.
> So can't even do that...

Hi,
Were was your problem solved? I faced the same issue recently with
ubuntu and it got fixed when i installed libxlst-devel. I used synaptic
Package manager to get the same since yum and apt-get both used to say
that the package was not found.
Just wanted to know what you did.

Thanks and Regards,
Anjali
This topic is locked and can not be replied to.