Forum: GNU Radio GRC control over flowgraph programs

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
davek (Guest)
on 2009-03-13 07:46
(Received via mailing list)
this has been discussed before, but i cant find the solution...
im wondering if there is options i need to pass to grc to make it more
resposive while running. A simple grc flowgraph connecting a USRP
source to a FFT sink works fine, but is unresponsive to any input,
eventually ubuntu will pop up a "NOT RESPONDING" windows and let me
kill the process. when i run usrp_fft.py It works fine, letting me
change options, gain and able to close. What do i need to add to my
simple GRC program to allow user input?
Josh B. (Guest)
on 2009-03-13 08:20
(Received via mailing list)
Hmm, seems like there is no available CPU for the GUI to respond, maybe
try lowering your frame rate for fft sink.

I have no idea what version of gnuradio or grc you are running. GRC is
bundled with gnuradio development trunk and gnuradio 3.2 release branch.
Install one of those gnuradio versions if you have not already done so.

If you still have the trouble, send the generated python code so we can
all take a look.

-Josh
This topic is locked and can not be replied to.