Forum: GNU Radio psk implementation problem

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
harshal jadhav (Guest)
on 2009-03-10 00:24
(Received via mailing list)
Attachment: test8.grc.xml.png (0 Bytes)
Hi,

I am attaching a screenshot of PSK implementation.
But when i run the flowgraph i am confronted with the following error

Executing: "/home/harshal/test8.grc.xml"
>>> Verbose:
Traceback (most recent call last):
  File "/usr/share/grc/src/ExecFlowGraphGUI.py", line 231, in OnInit
    self.SetTopWindow(FlowGraphFrame(self.flow_graph_file_path))#first
argument is the flow graph
  File "/usr/share/grc/src/ExecFlowGraphGUI.py", line 159, in __init__
    FlowGraphBuilder.__init__(self, file_path)
  File "/usr/share/grc/src/ExecFlowGraph.py", line 50, in __init__

self._parse_nested_data(ParseXML.from_xml(ParseXML.from_file(file_path)))
  File "/usr/share/grc/src/ExecFlowGraph.py", line 145, in
_parse_nested_data
    signal_blocks_dict[signal_block.get_id()] =
runnable_signal_block(*data_type_params)
  File "/usr/share/grc/src/SignalBlockDefs/Sources.py", line 146, in
make
    return fcn(vector, repeat.parse())
  File
"/usr/lib/python2.5/site-packages/gnuradio/gr/gnuradio_swig_py_gengen.py",
line 9262, in vector_source_b
    return _gnuradio_swig_py_gengen.vector_source_b(*args)
NotImplementedError: Wrong number of arguments for overloaded function
'vector_source_b'.
  Possible C/C++ prototypes are:
    gr_make_vector_source_b(std::vector< unsigned char,std::allocator<
unsigned char > > const &,bool)
    gr_make_vector_source_b(std::vector< unsigned char,std::allocator<
unsigned char > > const &)


>>> Done

Am i missing something obvious?

Regards,
Harshal Jadhav
Josh B. (Guest)
on 2009-03-10 00:54
(Received via mailing list)
Hi Harshal,

You are using a very old version of GRC (0.70?). Because this version
does not come with gnuradio, there are guaranteed compatibility issues.
These issues will not be fixed.

Install a version of gnuradio that comes with GRC (either gnuradio
trunk, or 3.2 release branch). That way, GRC is guaranteed to work with
your gnuradio install.

If you have trouble installing gnuradio trunk, or 3.2 release branch,
contact this mailing-list.

-Josh
This topic is locked and can not be replied to.