Forum: Ruby on Rails Disqus Gem; creating new threads

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Ramon T. (Guest)
on 2009-03-07 16:36
(Received via mailing list)
Hey everyone,

I need a bit of help with the Disqus gem.  I can't seem to create new
threads.  Just to test it out, I tried to create a thread in the
console:

>> Disqus::Api.thread_by_identifier(:forum_api_key => "the api key of the forum i want to 
post this comment in", :identifier => "some nutty one", :title => "test title")
TypeError: can't convert Net::HTTPMovedPermanently into String
  from
/home/ramon/.gem/ruby/1.8/gems/json-1.1.3/lib/json/common.rb:122:in
`initialize'
  from
/home/ramon/.gem/ruby/1.8/gems/json-1.1.3/lib/json/common.rb:122:in
`new'
  from
/home/ramon/.gem/ruby/1.8/gems/json-1.1.3/lib/json/common.rb:122:in
`parse'
  from
/usr/lib/ruby/gems/1.8/gems/norman-disqus-1.0.1/lib/disqus/api.rb:188:in
`thread_by_identifier'
  from (irb):1

I did some reading to see what the problem might be here, and it is
possible that it's because the browser sends a bunch of other stuff
that the server needs.  So I tried to curl it instead:

curl -d
"forum_api_key=myforumsapi&identifier=blogpost3020&=title=testtitle"
http://disqus.com/api/thread_by_identifier

When I press enter, nothing happens.  I checked my forum, and don't
see any new threads.

What should I do?

Thanks,
Ramon T.
Ramon T. (Guest)
on 2009-03-07 16:57
(Received via mailing list)
Okay I did more playing around, got the curl to work by wrapping the
URL with quotes :s

Now I know the API works (yes, I got to that point), I still need to
figure out why I can't do it in the console... unless I really am not
supposed to be able to do it on the console.

Ramon T.
Ramon T. (Guest)
on 2009-03-09 04:07
(Received via mailing list)
Spent more time testing it out.. and I manually typed out the code
that thread_by_identifier is composed of.  Apparently, the gem was
missing a "/" at the end of the api URL -- it should be
"http://disqus.com/thread_by_identifier/". I will send a bug report :)

I tried to fork and fix it myself but I realized I have no clue. I
asked around as well on rubyonrails but got no answer :P I guess it's
building only simple gems for me now.

Ramon T.
This topic is locked and can not be replied to.