Forum: Ruby on Rails ERB not omiting lines

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Eric G. (Guest)
on 2009-03-06 01:46
 According to numerous ERB tutorials, the following example:

  <%- [1,2,3].each do |x| -%>
  <%= x %>
  <%- end -%>


should output:

   1
   2
   3

Instead, it outputs:

   1

   2

   3

What am I doing wrong?
Robby R. (Guest)
on 2009-03-06 01:51
(Received via mailing list)
Try...

 <%= x -%>

On Thu, Mar 5, 2009 at 3:46 PM, Aryk G.
<removed_email_address@domain.invalid> wrote:
>   1
>
> What am I doing wrong?
> --
> Posted via http://www.ruby-forum.com/.
>
> >
>



--
Robby R.
Chief Evangelist, Partner

PLANET ARGON, LLC
design // development // hosting w/Ruby on Rails

http://planetargon.com/
http://robbyonrails.com/
http://twitter.com/planetargon
aim: planetargon

+1 503 445 2457
+1 877 55 ARGON [toll free]
+1 815 642 4068 [fax]
Eric G. (Guest)
on 2009-03-06 04:53
Nope, that didn't work. That actually causes that line to not show up.

Anybody else have any thoughts?

Aryk

Robby R. wrote:
> Try...
>
>  <%= x -%>
>
> On Thu, Mar 5, 2009 at 3:46 PM, Aryk G.
> <removed_email_address@domain.invalid> wrote:
>>   1
>>
>> What am I doing wrong?
>> --
>> Posted via http://www.ruby-forum.com/.
>>
>> >
>>
>
>
>
> --
> Robby R.
> Chief Evangelist, Partner
>
> PLANET ARGON, LLC
> design // development // hosting w/Ruby on Rails
>
> http://planetargon.com/
> http://robbyonrails.com/
> http://twitter.com/planetargon
> aim: planetargon
>
> +1 503 445 2457
> +1 877 55 ARGON [toll free]
> +1 815 642 4068 [fax]
This topic is locked and can not be replied to.