Forum: IronRuby gems and .gemrc

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Ivan P. (Guest)
on 2009-03-05 01:25
(Received via mailing list)
It looks like ironruby isn't happy with a .gemrc file this happens both
on
windows and mono.

+ivan@ivan-mbp:~/src/ironruby
(linux)» igem list

*** LOCAL GEMS ***


+ivan@ivan-mbp:~/src/ironruby
(linux)» igem install rake
ERROR:  While executing gem ... (URI::InvalidComponentError)
    bad component(expected absolute path component): latest_specs.4.8
+ivan@ivan-mbp:~/src/ironruby
(linux)» ls ~/.ge*
/Users/ivan/.gemrc

/Users/ivan/.gem:
jruby  latest_source_cache  ruby  source_cache  specs
+ivan@ivan-mbp:~/src/ironruby
(linux)» mv ~/.gemrc ~/.gemrc.old
+ivan@ivan-mbp:~/src/ironruby
(linux)» igem install rake
Successfully installed rake-0.8.4
1 gem installed
Installing ri documentation for rake-0.8.4...
Installing RDoc documentation for rake-0.8.4...
+ivan@ivan-mbp:~/src/ironruby
(linux)»
Jim D. (Guest)
on 2009-03-05 01:32
(Received via mailing list)
What is in your .gemrc? At one point IronRuby had problems with sources
that didn’t have a trailing slash.

JD

From: removed_email_address@domain.invalid
[mailto:removed_email_address@domain.invalid] On Behalf Of Ivan Porto
Carrero
Sent: Wednesday, March 04, 2009 3:25 PM
To: ironruby-core
Subject: [Ironruby-core] gems and .gemrc

It looks like ironruby isn't happy with a .gemrc file this happens both
on windows and mono.

+ivan@ivan-mbp:~/src/ironruby
(linux)» igem list

*** LOCAL GEMS ***


+ivan@ivan-mbp:~/src/ironruby
(linux)» igem install rake
ERROR:  While executing gem ... (URI::InvalidComponentError)
    bad component(expected absolute path component): latest_specs.4.8
+ivan@ivan-mbp:~/src/ironruby
(linux)» ls ~/.ge*
/Users/ivan/.gemrc

/Users/ivan/.gem:
jruby  latest_source_cache  ruby  source_cache  specs
+ivan@ivan-mbp:~/src/ironruby
(linux)» mv ~/.gemrc ~/.gemrc.old
+ivan@ivan-mbp:~/src/ironruby
(linux)» igem install rake
Successfully installed rake-0.8.4
1 gem installed
Installing ri documentation for rake-0.8.4...
Installing RDoc documentation for rake-0.8.4...
+ivan@ivan-mbp:~/src/ironruby
(linux)»
This topic is locked and can not be replied to.