Forum: GNU Radio starting with usrp2_fft.py

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
jeff . (Guest)
on 2009-02-27 16:07
(Received via mailing list)
Hi,

I'm a newbie. I received my hardware and trying test it.
I started to test the USRP2 (last release of firmware) and FLEX900 with
the
"usrp2_fft.py".
My system is Ubuntu 8.10 and the trunk version of gnuradio.

I'm trying this command:

#sudo usrp2_fft.py -f900M

But the graphic window of "USRP2 FFT" freezes and not responds anymore,
so I
need to kill the application. The spectrun don't show any communication
at
900Mhz, even with many radios working in this frequency.
If I try run again (sudo usrp2_fft.py -f900M) the following error
occurs:

    "RuntimeError: Unable to retrieve daughterboard info"

So I need turn off and turn on the USRP2 to stop the error and run the
"usrp2_fft.py -f900M" again.

What am I doing wrong?

Thank you!
Johnathan C. (Guest)
on 2009-03-02 23:21
(Received via mailing list)
On Fri, Feb 27, 2009 at 6:06 AM, jeff . <removed_email_address@domain.invalid> 
wrote:

> I'm a newbie. I received my hardware and trying test it.
> I started to test the USRP2 (last release of firmware) and FLEX900 with the
> "usrp2_fft.py".
> My system is Ubuntu 8.10 and the trunk version of gnuradio.

Can you confirm the version of the USRP2 FPGA code and firmware that
is written to the SD card, as well as the revision number of the
"latest trunk" that you have installed on your system?

Johnathan
jeff . (Guest)
on 2009-03-03 19:10
(Received via mailing list)
Hi!

The informations of my development environment are:
Revision: 10526
Last Changed Author: matt
Last Changed Rev: 10524
Last Changed Date: 2009-02-26 01:44:02 -0300 (Qui, 26 Fev 2009)

The informations about my USRP2 are:
firmware: txrx-edk10.1-r10524.bin
FPGA:    u2_rev3_ise10.1sp3_r10524.bin

Thank you,

Ps.: For all now :-)

Jeff


2009/3/2 Johnathan C. <removed_email_address@domain.invalid>
Shih-shen L. (Guest)
on 2009-03-04 04:20
jeff . wrote:
> Hi,
>
> I'm a newbie. I received my hardware and trying test it.
> I started to test the USRP2 (last release of firmware) and FLEX900 with
> the
> "usrp2_fft.py".
> My system is Ubuntu 8.10 and the trunk version of gnuradio.
>
> I'm trying this command:
>
> #sudo usrp2_fft.py -f900M
>
> But the graphic window of "USRP2 FFT" freezes and not responds anymore,
> so I
No any response? Maybe the host pc loading is too heavy.
What is the horsepower of CPU?
> need to kill the application. The spectrun don't show any communication
> at
> 900Mhz, even with many radios working in this frequency.
> If I try run again (sudo usrp2_fft.py -f900M) the following error
> occurs:
>
>     "RuntimeError: Unable to retrieve daughterboard info"
Maybe it is still running.
>
> So I need turn off and turn on the USRP2 to stop the error and run the
> "usrp2_fft.py -f900M" again.
>
> What am I doing wrong?
>
> Thank you!


Shih-Shen
Newman, Timothy (Guest)
on 2009-03-04 05:10
(Received via mailing list)
_______________________________________________
Discuss-gnuradio mailing list
removed_email_address@domain.invalid
http://lists.gnu.org/mailman/listinfo/discuss-gnuradio
leferman (Guest)
on 2009-03-19 19:33
(Received via mailing list)
I am having a similar problem.  I used ethtool to disable the pause
parameters for this interface; here is the output:
sudo ethtool -a eth1
Pause parameters for eth1:
Autonegotiate:  off
RX:    off
TX:    off

But I still get this error when i run tx_samples:
sudo ./tx_samples -e eth1
terminate called after throwing an instance of 'std::runtime_error'
  what():  Unable to retrieve daughterboard info
Creating USRP2 Object.... Aborted

I'm running the latest version of GNU Radio (freshly re-complied this
morning, revision 10644) on Ubuntu 8.10.  I have a USRP2 with the
firmware
and bit file that was complied on March 15th 2009 and the xcvr2450
daughterboard.

Are there any other ideas as to what could cause this (or did I disable
flow
control pause wrong)?  Thanks!



Newman, Timothy wrote:
>
> .
> Revision: 10526
> Ps.: For all now :-)
>> I started to test the USRP2 (last release of firmware) and FLEX900 with
>
>
>
>
> _______________________________________________
> Discuss-gnuradio mailing list
> removed_email_address@domain.invalid
> http://lists.gnu.org/mailman/listinfo/discuss-gnuradio
>
>

--
View this message in context:
http://www.nabble.com/starting-with-usrp2_fft.py-t...
Sent from the GnuRadio mailing list archive at Nabble.com.
Eric B. (Guest)
on 2009-03-19 20:14
(Received via mailing list)
On Thu, Mar 19, 2009 at 09:28:36AM -0700, leferman wrote:
> sudo ./tx_samples -e eth1
> control pause wrong)?  Thanks!
Please see this message from yesterday:

  http://lists.gnu.org/archive/html/discuss-gnuradio...

Try the new firmware without forcing anything with ethtool.  (Leave
autonegotiation enabled.)  It should come up with a sensible answer.


On my system I get:

    [eb@octo trunk]$ ethtool -a eth1
    Pause parameters for eth1:
    Autonegotiate:  on
    RX:             on
    TX:             off

Which is what I expect.

Eric
This topic is locked and can not be replied to.