Forum: Ruby on Rails blacklist

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
madhavi.k (Guest)
on 2009-02-27 12:48
(Received via mailing list)
hello all,

I installed blacklist plugin from the link------------
 http://github.com/watsonian/blacklist/tree/master.

when start the server I am getting  as below :

C:\Documents and Settings\Madhavi\Desktop\madhavi_moments
\madhavi_moments>ruby script/server
=> Booting WEBrick...
c:/ruby/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/commands/servers/
webrick.rb:13: w
arning: already initialized constant OPTIONS
=> Booting WEBrick...
c:/ruby/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/commands/servers/
webrick.rb:13: w
arning: already initialized constant OPTIONS
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_re
quire': no such file to load -- RedCloth (MissingSourceFile)
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
27:in `re
quire'
        from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.0.2/lib/
active_suppo
rt/dependencies.rb:496:in `require'
        from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.0.2/lib/
active_suppo
rt/dependencies.rb:342:in `new_constants_in'
        from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.0.2/lib/
active_suppo
rt/dependencies.rb:496:in `require'
        from C:/Documents and Settings/Madhavi/Desktop/madhavi_moments/
madhavi_m
oments/vendor/plugins/watsonian-blacklist/watsonian-blacklist/lib/
black_list.rb:
31
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
27:in `ge
m_original_require'
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
27:in `re
quire'
        from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.0.2/lib/
active_suppo
rt/dependencies.rb:496:in `require'
         ... 26 levels...
        from c:/ruby/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/commands/
server.rb:3
9
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
32:in `ge
m_original_require'
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
32:in `re
quire'
        from script/server:3

C:\Documents and Settings\Madhavi\Desktop\madhavi_moments
\madhavi_moments>



can anybody help me plzzz ?
vimal (Guest)
on 2009-02-27 12:53
(Received via mailing list)
install the RedCloth plugin using gem
madhavi.k (Guest)
on 2009-02-27 13:20
(Received via mailing list)
Thank u

But I couldnt fink the link for   Redcloth plugin .
can u suggest a link for that.
vimal (Guest)
on 2009-02-27 13:23
(Received via mailing list)
whenever u r unfamiliar with the gem
try:

gem search RedCloth --remote

gem install Redcloth
madhavi.k (Guest)
on 2009-02-27 14:01
(Received via mailing list)
I installed Recloth successfully...
Im following this link :
http://github.com/watsonian/blacklist/tree/master
for blacklist words...

Is it necessary to write code in my application beyond this
installation ???
If so guide me.

Can any body help me out?

Thank you
vimal (Guest)
on 2009-02-27 14:09
(Received via mailing list)
I haven't used blacklist either
I just traced the error in ur code
---------------------------------------------------------------------------------------
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require': no such file to load -- RedCloth
(MissingSourceFile)
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:
        27:in
----------------------------------------------------------------------------------------
I guess the blacklist gem needs RedCloth(a dependency) too

Just try to restart the server and check for errors.i think there wont
be any other additional code
Try to get the follow through in the Blacklist documentation correct
madhavi.k (Guest)
on 2009-02-27 14:47
(Received via mailing list)
Is there any links for list out the badwords in rails application?
This topic is locked and can not be replied to.