Forum: Ruby on Rails mysql.so errors with MySQL 5.0.77

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Rob N. (Guest)
on 2009-02-24 16:31
I have updated Rails to 2.2.2 and then found I had to update MySQL to
work with the mysql gem. However, I've found that with MySQL 5.0.77, I
get this error:

LoadError (126: The specified module could not be found.   -
c:/ruby/lib/ruby/gems/1.8/gems/mysql-2.7.3-x86-mswin32/ext/mysql.so)

Google search suggested removing the mysql.so but that didn't fix the
problem. However, downgrading MySQL to version 5.0.18 (the version I had
running on a development PC that wasn't getting an error) fixed the
problem.

Another thread:

http://groups.google.com/group/rubyonrails-talk/br...

Suggests problems with MySQL 5.0.27. It looks to me that the mysql gem
on Windows systems is very dependant on MySQL version.

OS Windows 2003 server.
This topic is locked and can not be replied to.