Forum: Ruby on Rails rspec dependencies

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Arshak N. (Guest)
on 2009-02-23 23:20
Hello,

I followed this

http://cheat.errtheblog.com/s/rspec/

to try to get rspec working with rails 2.2.2 and installed

rspec and rack gems

but I'm still getting the following messages

c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_re
quire': no such file to load -- spec/autorun (MissingSourceFile)

c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_re
quire': no such file to load -- spec/test/unit (MissingSourceFile)

Thx,

Arshak
Robby R. (Guest)
on 2009-02-23 23:28
(Received via mailing list)
Try these instructions:

http://wiki.github.com/dchelimsky/rspec/rails

The cheat for rspec could be out of date.

Robby

On Mon, Feb 23, 2009 at 1:20 PM, Arshak N.
<removed_email_address@domain.invalid> wrote:
>
> Thx,
>
> Arshak
> --
> Posted via http://www.ruby-forum.com/.
>
> >
>



--
Robby R.
Chief Evangelist, Partner

PLANET ARGON, LLC
design // development // hosting w/Ruby on Rails

http://planetargon.com/
http://robbyonrails.com/
http://twitter.com/planetargon
aim: planetargon

+1 503 445 2457
+1 877 55 ARGON [toll free]
+1 815 642 4068 [fax]
Arshak N. (Guest)
on 2009-02-24 00:27
Robby,

Thanks.  I had both installed as plugins and switched to gems (after I
uninstalled the plugins) but still get that autorun error.

Arshak



Robby R. wrote:
> Try these instructions:
>
> http://wiki.github.com/dchelimsky/rspec/rails
>
> The cheat for rspec could be out of date.
>
> Robby
>
> On Mon, Feb 23, 2009 at 1:20 PM, Arshak N.
> <removed_email_address@domain.invalid> wrote:
>>
>> Thx,
>>
>> Arshak
>> --
>> Posted via http://www.ruby-forum.com/.
>>
>> >
>>
>
>
>
> --
> Robby R.
> Chief Evangelist, Partner
>
> PLANET ARGON, LLC
> design // development // hosting w/Ruby on Rails
>
> http://planetargon.com/
> http://robbyonrails.com/
> http://twitter.com/planetargon
> aim: planetargon
>
> +1 503 445 2457
> +1 877 55 ARGON [toll free]
> +1 815 642 4068 [fax]
Steve R. (Guest)
on 2009-02-24 03:15
(Received via mailing list)
Did you do script/generate rspec

?

Hunted and pecked from my iPhone

On Feb 23, 2009, at 2:27 PM, Arshak N.
<removed_email_address@domain.invalid
Arshak N. (Guest)
on 2009-02-24 19:29
Steve,

Sure did, and it generated spec/spec_helper.rb, etc.

Hope all is well, btw :)

Arshak

Steve R. wrote:
> Did you do script/generate rspec
>
> ?
>
> Hunted and pecked from my iPhone
>
> On Feb 23, 2009, at 2:27 PM, Arshak N.
> <removed_email_address@domain.invalid
mamooth (Guest)
on 2009-03-10 14:08
(Received via mailing list)
If it can help, I was having the same problem. I solved it in removing
both, plugins (rspec and rspec_rails) AND all "./script/generate
rspec" generated files. After re running  ./script/generate rspec, all
was working fine.

On 23 fév, 23:27, Arshak N. <removed_email_address@domain.invalid>
This topic is locked and can not be replied to.