Forum: Ruby on Rails activemerchant + activesupport install/dependency issues

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
(Guest)
on 2009-02-23 11:31
(Received via mailing list)
Hi all:

Saw the awesome railscasts episode on activemerchant and am going to
give it a try, but keep running into this install problem that I can't
figure out:  after installing activemerchant as a gem, my rake keep
aborting with this error:

/Library/Ruby/Site/1.8/rubygems.rb:149:in `activate': can't activate
activesupport (>= 1.4.1, runtime), already activated
activesupport-2.1.0 (Gem::Exception)

I've tried uninstalling all the gems and reinstalling, installing
activemerchant 1.4.0 to no avail.  No info that I can find on this
error that I can find either.  Help would be much appreciated!

BTW, not sure if this trace from rake gems:install with trace is more
useful:

william$ sudo rake gems:install --trace
(in /Users/william/Code/lolligift/trunk)
** Invoke gems:install (first_time)
** Invoke gems:base (first_time)
** Execute gems:base
** Invoke environment (first_time)
** Execute environment
Sarah Mei (Guest)
on 2009-02-23 19:52
(Received via mailing list)
activemerchant requires activesupport >= 2.0.0, and that's being loaded
ok.

Then some other gem is requiring activesupport 1.4.1, but since 2.1.0
is already loaded it can't load 1.4.1.

You should run gem cleanup to remove old versions of activesupport. If
that doesn't fix it, you'll need to locate the gem that's requiring
the older version and try modifying it to take the newer version.
This topic is locked and can not be replied to.