Forum: Typo can't install typo

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Darius (Guest)
on 2009-02-22 00:10
(Received via mailing list)
Hello,

I try install typo, on my local machine, after set database config, i
try start application and get fallowing error:

/usr/local/lib/site_ruby/1.8/rubygems.rb:149:in `activate': can't
activate actionpack (= 1.13.6, runtime), already activated
actionpack-2.2.2 (Gem::Exception)
        from /usr/local/lib/site_ruby/1.8/rubygems.rb:165:in `activate'
        from /usr/local/lib/site_ruby/1.8/rubygems.rb:164:in `each'
        from /usr/local/lib/site_ruby/1.8/rubygems.rb:164:in `activate'
        from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:35:in `require'
        from
/var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
`require'
        from
/var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:521:in
`new_constants_in'
        from
/var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
`require'
        from
/var/lib/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:256:in
`require_frameworks'
        from
/var/lib/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:256:in `each'
        from
/var/lib/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:256:in
`require_frameworks'
        from
/var/lib/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:133:in `process'
        from
/var/lib/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:112:in `send'
        from
/var/lib/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:112:in `run'
        from /home/darius/workspace/github/typo/config/environment.rb:19
        from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
        from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from
/var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
`require'
        from
/var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:521:in
`new_constants_in'
        from
/var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
`require'
        from
/var/lib/gems/1.8/gems/rails-2.2.2/lib/commands/servers/webrick.rb:59
        from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
        from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from
/var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
`require'
        from
/var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:521:in
`new_constants_in'
        from
/var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
`require'
        from
/var/lib/gems/1.8/gems/rails-2.2.2/lib/commands/server.rb:49
        from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
        from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from script/server:3

it seems like problem with actionpack, i have installed fallowing
versions actionpack 2.2.2, 2.0.2, 1.13.6
maybe someone know how to fix it ?
Tobias W. (Guest)
on 2009-02-22 00:18
(Received via mailing list)
Hi there,

I am trying to figure out the exact same problem here.

I tried to run "rake db:migrate" and get similar issues.

I tried to get rid of old versions of gems by "sudo gem cleanup" which
solved the problem you are having right now just to run into the next
problem. Try this first and please let me know on this list if this
resolved
it for you.

Thanks,

Tobias
Darius (Guest)
on 2009-02-22 11:43
(Received via mailing list)
cleanup doesn't help, but thank you, you put me on the right way :) ,
problem is because lastest actionwebservice from gems  depends on
ationpack 1.13.6, activerecord 1.15.6 and activesupport 1.4.4

i  install actionwebservice from github ant its work :)
Ivan C. (Guest)
on 2009-03-07 17:28
Darius wrote:
> cleanup doesn't help, but thank you, you put me on the right way :) ,
> problem is because lastest actionwebservice from gems  depends on
> ationpack 1.13.6, activerecord 1.15.6 and activesupport 1.4.4
>
> i  install actionwebservice from github ant its work :)

Me too.  I got actionwebservice from github and extract that file and
rename actionwebservice but it not works.  Here is what i process to
install manually.

1) Extract the latest actionwebservice.zip
2) Put it in to C:\xxxx\ruby\lib\ruby\gems\1.8\gems and
actionwebservice.gemspec into
C:\xxxx\ruby\lib\ruby\gems\1.8\specifications.
3) Gem install actionwebservice.

... then i have still got the same problem with actionwebservice-1.2.6
from console.

How can i update the latest one please?
Darius (Guest)
on 2009-03-07 19:12
(Received via mailing list)
did you install this
http://github.com/datanoise/actionwebservice/tree/master  ?

in my setup gem list --local show this:
datanoise-actionwebservice (2.2.2)
Harry S. (Guest)
on 2009-03-08 19:48
For info, check this post for news about Typo:
http://harryseldon.thinkosphere.com/2009/03/08/new...
This topic is locked and can not be replied to.