Forum: Ruby on Rails NoMethodError with custom RAILS_ENV

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Filip T. (Guest)
on 2009-02-21 13:10
(Received via mailing list)
Hi,

I've just deployed my application to staging server, using
RAILS_ENV=staging (Ruby 1.8.7, mod_rails). The application works fine
in production (using setup as above), but I keep on getting this error
(both in mod_rails and WEBrick):

Processing ApplicationController#index (for 79.184.115.252 at
2009-02-21 09:13:47) [GET]

NoMethodError (undefined method `+' for nil:NilClass):

Any ideas?

Regards,
Filip T.
Frederick C. (Guest)
on 2009-02-21 13:10
(Received via mailing list)
On Feb 21, 9:13 am, Filip T. <removed_email_address@domain.invalid> wrote:
> Hi,
>
> I've just deployed my application to staging server, using
> RAILS_ENV=staging (Ruby 1.8.7, mod_rails). The application works fine
> in production (using setup as above), but I keep on getting this error
> (both in mod_rails and WEBrick):

I'd start by looking at the backtrace to see where that error occurs.

Fred
Dharmdip R. (Guest)
on 2009-02-21 13:12
On which platform r u deploying your application?
Filip T. (Guest)
on 2009-02-25 10:00
(Received via mailing list)
On Feb 21, 12:09 pm, Frederick C. <removed_email_address@domain.invalid>
wrote:

> I'd start by looking at the backtrace to see where that error occurs.

No backtrace! Just this error!

Regards,
Filip T.
Filip T. (Guest)
on 2009-02-25 10:00
(Received via mailing list)
On Feb 21, 12:12 pm, Dharmdip R. <rails-mailing-l...@andreas-
s.net> wrote:

> On which platform r u deploying your application?

Debian, tried both 4.0 and 5.0. Local deployment on OS X 10.5.6.

Regards,
Filip T.
This topic is locked and can not be replied to.