Forum: Ruby on Rails Blackbook

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Kivanc G. (Guest)
on 2009-02-20 09:36
When I run the following piece of code;
@gmail_xml = Blackbook.get :username => 'removed_email_address@domain.invalid', 
=> 'pwd', :as => :xml

Hotmail and yahoo work fine. But with gmail I get the following error:

Nokogiri::CSS::SyntaxError in ItemsController#index

unexpected '.' after '.'

RAILS_ROOT: C:/Documents and
Application Trace | Framework Trace | Full Trace

racc/parser.rb:99:in `_racc_do_parse_c'
racc/parser.rb:99:in `__send__'
racc/parser.rb:99:in `do_parse'
app/controllers/items_controller.rb:9:in `index'

Any help would really be appreciated. I couldnot see anyone who got the
same error.
Sazima (Guest)
on 2009-02-20 16:57
(Received via mailing list)

I used Contacts (GMail, Hotmail, Yahoo, Facebook, etc) and it worked
like a charm:

      . gem install json-1.1.1-mswin32.gem
      . gem install contacts

Cheers, Sazima

On Feb 20, 4:36 am, Kivanc G. <removed_email_address@domain.invalid>
Trevor E. (Guest)
on 2009-04-20 22:49
I actually got this exact same error with gmail. I was wondering if you
ever found a solution?
This topic is locked and can not be replied to.