Forum: Ruby on Rails Rails Framework

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
(Guest)
on 2009-02-17 11:34
(Received via mailing list)
When I try to create new rails framework I' getting the follow error.
I've had to reinstall ruby and ruby gem.

/Library/Ruby/Site/1.8/rubygems.rb:149:in `activate': can't activate
activesupport (= 2.1.0, runtime), already activated
activesupport-2.2.2 (Gem::Exception)
  from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:35:in
`require'
  from /Users/brianspadetti/.gem/ruby/1.8/gems/rails-2.2.2/bin/../lib/
rails_generator.rb:28
  from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
  from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
`require'
  from /Users/brianspadetti/.gem/ruby/1.8/gems/rails-2.2.2/bin/rails:13
  from /usr/bin/rails:19:in `load'
  from /usr/bin/rails:19
Please help
Jeff E. (Guest)
on 2009-02-17 17:57
(Received via mailing list)
Show:

ruby -v
gem -v
gem list
(Guest)
on 2009-02-19 18:15
(Received via mailing list)
ruby 1.8.7 (2008-08-11 patchlevel 72) [i686-darwin9]
gem -v 1.3.1

actionmailer (2.2.2, 2.1.0)
actionpack (2.2.2, 2.1.0)
activerecord (2.2.2, 2.1.0)
activeresource (2.2.2, 2.1.0)
activesupport (2.2.2, 2.1.0)
acts_as_ferret (0.4.3)
addressable (2.0.2)
capistrano (2.5.4)
daemons (1.0.10)
data_objects (0.9.11)
dnssd (0.7.0)
extlib (0.9.10)
ferret (0.11.6)
highline (1.5.0)
hpricot (0.6.164)
libxml-ruby (0.9.8)
mongrel (1.1.5)
net-scp (1.0.2)
net-sftp (2.0.2)
net-ssh (2.0.10)
net-ssh-gateway (1.0.1)
rails (2.2.2, 2.1.0)
rake (0.8.3)
RedCloth (4.1.1)
ruby-openid (2.1.4)
rubynode (0.1.5)
(Guest)
on 2009-02-19 21:57
(Received via mailing list)
should I remove or downgrade any versions that are 2.2.2? If so how
would I uninstall and reinstall because I installed everything threw
macports
(Guest)
on 2009-02-19 21:57
(Received via mailing list)
should I remove or downgrade any versions that are 2.2.2? If so how
would I uninstall and reinstall because I installed everything threw
macports
Jeff E. (Guest)
on 2009-02-24 17:42
(Received via mailing list)
I believe I had a similar problem once, either caused by multiple
versions of Rails installed or by having some version of Rails frozen
into vendor/rails

My solution was to remove the offending version since I wasn't locked
to a specific version.
Brian Spadetti (Guest)
on 2009-02-24 17:50
(Received via mailing list)
I figured it out. Thank you for your help. Issues I had was I install
ruby
under gem and tried to remove it. Then I tried to install in macports
which
cause the issues because ruby was making references to other instances
if
that makes sense?

Brian
This topic is locked and can not be replied to.