Forum: RSpec [cucumber] can't use 'visit' except with `rake features`

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
unknown (Guest)
on 2009-02-16 02:03
(Received via mailing list)
I ported some stories from restful_authentication so that they can use
cucumber, and it worked fine in `rake features`.

Now when I try to run under autospec or `cucumber features`, I'm getting
failures with undefined method `get'.  When I change 'get' to 'visit',
same symptom (undefined method `visit'), but I'm getting other issues
(redirects not being detected or issued) when running in rake.

I can't see that I'm doing anything out of the ordinary.  I have require
"webrat/rails" in my support/env.rb, along with... well, here's my
env.rb:

  http://gist.github.com/64875

Anybody have ideas what could be going on here?

Thanks,

Randy
James B. (Guest)
on 2009-02-16 04:39
unknown wrote:

how are you invoking cucumber from the command line?
unknown (Guest)
on 2009-02-16 08:30
(Received via mailing list)
I'm running it like so:

$ cucumber features/

I've also tried using

  --require config/boot.rb --require features
  --require config/environment.rb

and now, I've tried with

  --require lib --require features features/  (nope)

  --require features --require lib features/  (yes!)

Shazaaaayam!  Okay, thank you for the hint.  Lessee, then for
autospec... aha.  Yep.  cucumber.yml, check.  Added these working args
to the autotest and autotest-all config, working well now.

Okay, updated the wiki page to add some details.  These work for me now.

http://wiki.github.com/aslakhellesoy/cucumber/ruby-on-rails


I'd appreciate a review of this stuff I've added - hopefully it provides
more help than harm to others in my situation. :)

Thanks,

Randy



----- Original Message ----
This topic is locked and can not be replied to.