Forum: Ruby on Rails I get “Missing these required gems”, but gems are installed

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Marco C. (Guest)
on 2009-02-14 22:44
Hi,

since I updated ruby using Mac Ports (on Leopard) I have got several
problems and I also had to reinstall gems. Now when I run Mongrel I keep
getting the error "Missing these required gems" followed by the list of
gems that I required in environment.rb but that gems seems to be
correctly installed as I see running gem list.
I think that rails is looking for a previous installation, but I don't
know how to configure it to use the new ruby/gem path.

Thanks in advance!
Freddy A. (Guest)
on 2009-02-15 06:36
(Received via mailing list)
Gems might be installed in more than one area.

Look in ~/.gems and make sure that you use sudo when installing gems.

Do you now have multiple ruby directories on your mac? if so you most
likely have multiple gems directories too...

what I found was best when I upgraded from 1.8.6 to 1.8.7 was to
remove all gems directories and start empty. I can't remember what the
issue was but it was a path issue or something like that.
Marco C. (Guest)
on 2009-02-15 14:32
Freddy A. wrote:
> Gems might be installed in more than one area.

I agree..

> Look in ~/.gems and make sure that you use sudo when installing gems.

Unfortunately I haven't got any ~/.gems directory

> Do you now have multiple ruby directories on your mac? if so you most
> likely have multiple gems directories too...

When I upgraded from 1.8.6 to 1.8.7 I used MacPorts and I found out that
I had two versions of Ruby, but the first installation was then removed
(I think so).

> what I found was best when I upgraded from 1.8.6 to 1.8.7 was to
> remove all gems directories and start empty. I can't remember what the
> issue was but it was a path issue or something like that.

$ which ruby
/opt/local/bin/ruby
$ which gem
/opt/local/bin/gem
Marco C. (Guest)
on 2009-02-15 21:32
Oops.. I've resolved. The problem wasn't related to ruby path: when I
set  environment.rb I forgot to specify the :lib parameter for some
gems.

Sorry
This topic is locked and can not be replied to.