Forum: GNU Radio UDP do not work correctly

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
feldmaus (Guest)
on 2009-02-13 16:21
(Received via mailing list)
Hi Gnuradio People, :-)

I tried to get the <UDP sink> and <UDP source> to work.
But it didn't work as it should. The FFT Plots only
shows a white screen. The CPU of my Work PC is under
100% and my Server PC too. Should this be a Problem of
<threads> ?
I have a network traffic between the connected pc's with
about 300Kbyte/s.

Do you have any hints for me?

Specification:
Work PC:
+ IP 194.94.26.158
+ Firewall with open UDP Port 13130:13133

Server PC:
+ IP 192.168.111.67
+ Firewall with open UDP Port 13130:13133

The Firewall was tested with <nmap -p 13130-13133 -sU IP-ADRESS>.

So i created a Flow Graph:
#######################################################
###SERVER PC###
[SIN Source]--\    /-->[USRP Sink]
              +-->+
[COS SOURCE]--/    \-->[UDP Sink 1]

SETTINGS for UDP Sink 1:
  Local IP Address: 192.168.111.67
  Port: 13130
  Remote IP Address: 194.94.26.158
  Port: 13132


[USRP Source]-->[UDP SINK 2]

SETTINGS for UDP Sink 1:
  Local IP Address: 192.168.111.67
  Port: 13131
  Remote IP Address: 194.94.26.158
  Port: 13133




###WORK PC###
[UDP Source1]-->[FFT Plot TX]

SETTINGS for UDP Source1:
  IP Address: 194.94.26.158
  Port: 13132

[UDP Source2]-->[FFT Plot RX]

SETTINGS for UDP Source2:
  IP Address: 194.94.26.158
  Port: 13133
#######################################################

Regards Markus
Jason U. (Guest)
on 2009-02-13 16:45
(Received via mailing list)
> Do you have any hints for me?


Unless I am misunderstanding your diagram, I think you need something
to slow down rate of the cosine source ([COS SOURCE]--/    \-->[UDP
Sink 1]).  If you connect it to a non-rate limited sink it will just
pump out samples as fast as it can, hence your 100% CPU usage.

Try a  gr.throttle() in between.


Jason
feldmaus (Guest)
on 2009-02-18 13:16
(Received via mailing list)
Jason U. <jasonuher <at> gmail.com> writes:

>
> > Do you have any hints for me?
>
> Unless I am misunderstanding your diagram, I think you need something
> to slow down rate of the cosine source ([COS SOURCE]--/    \-->[UDP
> Sink 1]).  If you connect it to a non-rate limited sink it will just
> pump out samples as fast as it can, hence your 100% CPU usage.
>
> Try a  gr.throttle() in between.
Ok i understand, but why do i need a <gr.throttle()> for the
FFT-Plot too ?
The <USRP Sink> do not have a variable <sample rate>, but the
<FFT-Plot> has a variable <sample rate>.
Is this a Bug ?
This topic is locked and can not be replied to.