Forum: Ruby on Rails i18n with Rails 2.1

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Jeba M. (Guest)
on 2009-02-12 14:56
Hi.
I'm currently using Rails 2.1.
But i want to use i18n to internationalize my rails application.
I'm trying to install rails 2.2 using:
gem update rails
but it gives me an error...
Can anyone please suggest..how do I do this???
Thank You.
Mathieu R. (Guest)
on 2009-02-12 15:00
(Received via mailing list)
Maybe a little more detail would help... OS? Error?

On Thu, Feb 12, 2009 at 10:56 AM, Jeba M. <
Jeba M. (Guest)
on 2009-02-12 15:04
Mathieu R. wrote:
> Maybe a little more detail would help... OS? Error?
>
> On Thu, Feb 12, 2009 at 10:56 AM, Jeba M. <

OS:windows XP
Error:
ERROR:  While executing gem ... (Gem::RemoteFetcher::FetchError)
    bad response ( The request is not supported.  ) 500
(http://gems.rubyforge.v
m.bytemark.co.uk/gems/rails-2.2.2.gem)
Mathieu R. (Guest)
on 2009-02-12 15:12
(Received via mailing list)
The urls it tries to download the gem from is not working...

I do not know anything about mirrors, hope someone else here knows...

On Thu, Feb 12, 2009 at 11:04 AM, Jeba M. <
MaD (Guest)
on 2009-02-12 15:14
(Received via mailing list)
try specifying the source:
  gem update rails --source=http://gems.rubyforge.org

other than that try to update your rubygems.
Jeba M. (Guest)
on 2009-02-12 15:22
MaD wrote:
> try specifying the source:
>   gem update rails --source=http://gems.rubyforge.org
>
> other than that try to update your rubygems.

Hey..
Thank You so much...
that worked for me...
Thanks again...
Jeba M. (Guest)
on 2009-02-27 11:13
Jeba M. wrote:
> MaD wrote:
>> try specifying the source:
>>   gem update rails --source=http://gems.rubyforge.org
>>
>> other than that try to update your rubygems.
>
Hey...I'm trying to update rails on another m/c now...and I'm getting
the same error as before:


C:\Front End>gem update rails --source=http://gems.rubyforge.org
Updating installed gems
Updating rails
ERROR:  While executing gem ... (Gem::RemoteFetcher::FetchError)
    bad response ( The request is not supported.  ) 500
(http://gems.rubyforge.v
m.bytemark.co.uk/gems/actionmailer-2.2.2.gem)


Please can someone tell me..where am I going wrong????
Thank You...
MaD (Guest)
on 2009-02-27 11:41
(Received via mailing list)
http://gems.rubyforge.vm.bytemark.co.uk/gems/actio...

that address seems to be working. have you tried it again?
Jeba M. (Guest)
on 2009-02-27 12:01
MaD wrote:
> http://gems.rubyforge.vm.bytemark.co.uk/gems/actio...
>
> that address seems to be working. have you tried it again?

Hey...
It worked when I did this:
C:\>gem update rails --source=http://gems.rubyforge.org

'Front End' is my Rails application...
When I try doing gem update from within my rails application...only then
I get the error...!!!
Anyways...
Thanks a lot for your help..
This topic is locked and can not be replied to.