Forum: Ruby on Rails setting up remote rails

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
The Dro (Guest)
on 2009-02-11 23:52
(Received via mailing list)
I've got a remote machine on my network which has Ubuntu as the OS. I
run my testserver on it with all my current PHP sites. All I have to
type on my main Vista Machine as the URL is "http://testserver" and it
takes me to the index page i've created with links to all my sites on
that remote Ubuntu machine.

My question is:
I've setup RoR on that machine, but when I type testserver:3000 it
wont access that page. On the machine itself, I am able to see my RoR
project, but not on my main machine. I'm even able to SSH into the
testserver to work on the project files. How do I go about setting
that up?

My second Question is, Where are the config files to tell RoR to use
the MySQL database I currently have setup on the testserver that
phpmyadmin is also using? I have edited the database.yml file to
include the correct login information and the mysql adapter but it's
still not connecting properly to the database. Is there a certain file
I can setup the paths in for my MySQL db?

thanks in advance for your assistance,
David Herman (Guest)
on 2009-02-11 23:54
(Received via mailing list)
Have you installed the MySQL gem?
Freddy A. (Guest)
on 2009-02-12 02:05
(Received via mailing list)
- Does the server have firewall?

What does your database.yml look like?

  username: mysql_user
  adapter: mysql
  port: 3306
  password: mysql_password
  database: my_database
Mathieu R. (Guest)
on 2009-02-12 12:31
(Received via mailing list)
who did you start your ror server? which one are you using?
MaD (Guest)
on 2009-02-12 13:18
(Received via mailing list)
you might want to configure your apache (or whatever webserver you
use) to forward your mongrel on port 3000.
look for something like this (for your webserver and operation

as long as your database.yml is configured correctly you only need to
make sure that you have sufficient rights to access that database. run
  mysql -uroot -ppassword
and adjust settings (e.g. create database, grant access for chosen
This topic is locked and can not be replied to.