Forum: IronRuby igem.bat

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Jirapong N. (Guest)
on 2009-01-31 09:59
(Received via mailing list)
How can i get igem.bat work correctly? right now, I get following error.

C:\dotNET\ironruby\ironruby\Merlin\Main\Languages\Ruby\Scripts\bin>SET
GEM_PATH=C:\ruby\lib\ruby\gems\1.8

C:\dotNET\ironruby\ironruby\Merlin\Main\Languages\Ruby\Scripts\bin>set
path=%path%;C:\dotNET\ironruby\ironruby\Merlin\Ma
in\bin\debug;C:\ruby\lib\ruby\gems\1.8

C:\dotNET\ironruby\ironruby\Merlin\Main\Languages\Ruby\Scripts
\bin>igem.bat list
c:\dotNET\ironruby\ironruby\Merlin\Main\Languages\Ruby
\Libraries.LCA_RESTRICTED\Builtins\KernelOps.cs:406:in `require':
no such file to load -- rubygems (LoadError)
         from :0

Use latest version from GitHub (1ee05cdd)

Thank you,
-Jirapong
Ivan P. (Guest)
on 2009-01-31 11:01
(Received via mailing list)
You have to edit ir.exe.config and change the paths to reflect your
installation.
---
Met vriendelijke groeten - Best regards - Salutations
Ivan Porto C.
GSM: +32.486.787.582
Blog: http://flanders.co.nz
Twitter: http://twitter.com/casualjim



On Sat, Jan 31, 2009 at 8:30 AM, removed_email_address@domain.invalid <
Jirapong N. (Guest)
on 2009-02-02 04:21
(Received via mailing list)
Hello Ivan,
  ok, now i put

<set language='Ruby' option='LibraryPaths' value='C:\ruby\lib\ruby
\1.8;C:\ruby\lib\ruby\1.8\i386-mswin32;C:\dotNET\ironruby\ironruby
\Merlin\External\Languages\Ruby\redist-libs\ruby\site_ruby\1.8'/>

two errors after that.
c:\ironruby\Merlin\Main\Languages\Ruby\Libraries.LCA_RESTRICTED
\Builtins\KernelOps.cs:406:in `require': no such file to load --
thread.so (LoadError)
#this one resolve by put C:\ruby\lib\ruby\1.8\i386-mswin32  on
LibraryPaths

I cannot get around this error
c:\ironruby\Merlin\Main\Languages\Ruby\Libraries.LCA_RESTRICTED
\Builtins\KernelOps.cs:406:in `require':
The module was expected to contain an assembly manifest. (Exception
from HRESULT: 0x80131018) (LoadError)

Any advice?

Thank you,
-Jirapong             
This topic is locked and can not be replied to.