Forum: Typo [ANN] Typo 5.2 for Rails 2.2 released

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
de Villamil Frédéric (Guest)
on 2009-01-25 18:31
(Received via mailing list)
Hello,

We're very pleased and proud to announce the release of Typo 5.2
"Helmut Newton" for Rails 2.2, the famous blogging engine, 4 months
after our last release.

Typo 5.2 is more than a simple port from Rails 2.0.2 to Rails 2.2,
it's a major, deep, rewrite of the application. We've ditched lot of
code, aiming at stability and performance, dividing Typo's memory
footprint by 4 on some large blogs.

We've also fixed a huge, very huge amount of bugs, too many to be told
here, actually, from functionnal aberrations to security breaches. See
the CHANGLOG for more information.

There are also some new features.

* A brand new admin, focusing on both efficiency and usability.
* The new editor, coming with easy to use XHTML quicktags toolbar for
people who don't like FCK Editor.
* Search engine optimization everywhere on your blog. Too much to say
here.
* A new theme catalogue, allowing you to browse and download up to
date themes from your Typo install.
* Our old code syntax highlighting plugin has been replaced with
Coderay.
* Excerpts, that allow you to display on your index something
completely different as on your article, which won't appear on your
RSS feed.
* Our <em>live search</em>, which was so hype 2 years ago has been
replaced with a more traditionnal and clearer search engine and left
as a plugin.

And many more you can read about on the official release note:
http://blog.typosphere.org/2009/01/25/typo-5-2-hel...

You can download Typo 5.2 on Rubyforge:
http://rubyforge.org/frs/?group_id=555
  or using the good old gem
Install Typo from sources:
http://wiki.github.com/fdv/typo/install-typo-from-sources
Install with Typo installer:
http://wiki.github.com/fdv/typo/install-typo-with-...

Once again, thank you to every contributor who made it possible.
Hope you'll enjoy.

Frédéric and Cyril
--
Frédéric de Villamil
removed_email_address@domain.invalid                        tel: +33 (0)6 62 19 
1337
http://t37.net                       Typo : http://typosphere.org
Harry S. (Guest)
on 2009-01-25 19:22
Awesome work guys. Thanks. I have been using Typo for 6 months
now and I enjoy it more and more.

H
http://www.thinkosphere.com
http://harryseldon.thinkosphere.com
freak b. (Guest)
on 2009-02-17 11:27
I am having an issue upgrading from 5.1.3. I have:
1) installed the upgraded typo gem
2) run `typo install .` in my typo directory
3) cleared the sessions with rake db:sessions:clear
4) double checked the migrations have worked with rake db:migrate

The issue I have is this: When I try log in, it tries to navigate to
/admin/settings/update_database. This fails, and the logs contain the
following:

Processing Admin::SettingsController#update_database (for 121.98.143.175
at 2009-02-17 09:04:30) [GET]
  Session ID: e70ccad1ea97ae3270cfcc699458d192
Rendering template within layouts/administration
Rendering admin/settings/update_database


ActionView::TemplateError (undefined method `editor' for
#<User:0xb67c53c4>) on line #8 of
app/views/layouts/administration.html.erb:
5:   <meta http-equiv="Content-type" content="text/html; charset=utf-8"
/>
6:   <title>Typo Administration:  <%= controller.controller_name
%></title>
7:   <meta http-equiv="imagetoolbar" content="no" />
8:   <%= javascript_include_tag :fckeditor if current_user.editor == 2
%>
9:   <%= javascript_include_tag 'quicktags' if current_user.editor == 0
%>
10:   <%= stylesheet_link_tag "administration", "lightbox" %>
11:   <%= stylesheet_link_tag "administration_rtl" if (
_("Localization.rtl") == "1") %>

    vendor/rails/activerecord/lib/active_record/attribute_methods.rb:260:in
`method_missing'
    app/views/layouts/administration.html.erb:8

Any ideas as to how to fix this?

Cheers,
Jamie
Cyril M. (Guest)
on 2009-02-17 13:26
(Received via mailing list)
Jamie Penney wrote:
> Processing Admin::SettingsController#update_database (for 121.98.143.175
> />
>
>     vendor/rails/activerecord/lib/active_record/attribute_methods.rb:260:in
> `method_missing'
>     app/views/layouts/administration.html.erb:8
>
> Any ideas as to how to fix this?
>
>

The editor field is insert in Typo 5.2

Maybe try a restart of Typo, with delete all cookie and restart rake
db:migrate.

- Stop Typo
- rake db:sessions:clear
- rake db:migrate
- Start Typo

Maybe you are a old user model in your session or your migration failed.

--
Cyril M.
http://blog.shingara.fr
freak b. (Guest)
on 2009-02-17 21:59
I have done all of these things. I stopped mongrel, clear my sessions
and cookies in my browser, ran rake, restarted mongrel, and the problem
still exists.

Cyril M. wrote:
>
> The editor field is insert in Typo 5.2
>
> Maybe try a restart of Typo, with delete all cookie and restart rake
> db:migrate.
>
> - Stop Typo
> - rake db:sessions:clear
> - rake db:migrate
> - Start Typo
>
> Maybe you are a old user model in your session or your migration failed.
>
> --
> Cyril M.
> http://blog.shingara.fr
freak b. (Guest)
on 2009-02-18 07:16
 Cyril M. wrote:
>
> The editor field is insert in Typo 5.2
>
> Maybe try a restart of Typo, with delete all cookie and restart rake
> db:migrate.
>
> - Stop Typo
> - rake db:sessions:clear
> - rake db:migrate
> - Start Typo
>
> Maybe you are a old user model in your session or your migration failed.
>
> --
> Cyril M.
> http://blog.shingara.fr

I have fixed this by installing Typo in a different directory but
pointing to the same database. It re-ran the migrations, which seem to
have worked this time (I sear they ran the first time, but I guess not).
Now running the blog from the original directory works.
This topic is locked and can not be replied to.