Forum: Ruby on Rails Error: uninitialized constant Authlogic

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
(Guest)
on 2009-01-24 14:27
(Received via mailing list)
Hello,

I'm a Ruby / Rails beginner and tried to use the Authlogic plugin
which I have found here:
http://www.binarylogic.com/2008/11/3/tutorial-auth...

However I run into this error:

uninitialized constant Authlogic

Application Trace | Framework Trace | Full Trace

D:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.1.1/lib/active_support/
dependencies.rb:279:in `load_missing_constant'
D:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.1.1/lib/active_support/
dependencies.rb:468:in `const_missing'
D:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.1.1/lib/active_support/
dependencies.rb:480:in `const_missing'
app/models/user_session.rb:1
app/controllers/application.rb:12:in `current_user_session'
app/controllers/application.rb:17:in `current_user'
app/controllers/application.rb:32:in `require_no_user'

Perhaps you can point me somewhere to fix that. As I said, it's all
new...

Lucas.
ebrad (Guest)
on 2009-02-20 00:20
(Received via mailing list)
Sounds like you are using the Gem and not the plugin. You might have
forgot this:

# config/environment.rb
config.gem "authlogic"

On Jan 23, 3:49 pm, "removed_email_address@domain.invalid"
This topic is locked and can not be replied to.