Forum: Ruby on Rails Problem in installing mysql gem

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Suneeta K. (Guest)
on 2009-01-23 23:13
Hi...

I'm using mysql 5.1 and now tried to install the mysql gem:

C:\Ruby>gem install mysql

Successfully installed mysql-2.7.3-x86-mswin32
1 gem installed
Installing ri documentation for mysql-2.7.3-x86-mswin32...
Installing RDoc documentation for mysql-2.7.3-x86-mswin32...
ERROR:  While generating documentation for mysql-2.7.3-x86-mswin32
... MESSAGE:   Unhandled special: Special: type=17, text="<!-- $Id:
README.html,
v 1.20 2006-12-20 05:31:52 tommy Exp $ -->"
... RDOC args: --op
C:/Ruby/lib/ruby/gems/1.8/doc/mysql-2.7.3-x86-mswin32/rdoc -
-exclude ext --main README --quiet ext README docs/README.html
(continuing with the rest of the installation)

Then I tried to run the program... but got the following error message:

126: The specified module could not be found.   -
C:/Ruby/lib/ruby/gems/1.8/gems/mysql-2.7.3-x86-mswin32/ext/mysql.so


Please help me to find the solution.

Thanks
Regards
Suneeta
This topic is locked and can not be replied to.