Forum: Ruby on Rails script/plugin and polluted(?) sources

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Fritz A. (Guest)
on 2009-01-22 23:35
I recently had trouble installing the ssl_requirement plugin.
script/plugin said it couldn't find ssl_requirement.

I "solved" this by running "script/plugin discover" and accepting the
addition of a bunch of other repositories. The script could then
discover and install ssl_requirement.

BUT: It wasn't the same version of ssl_requirement that I'd installed
(and worked well with) on other projects. The version I got, in
SslRequirement::ensure_proper_protocol, made use of a module called
UserSystem, which I didn't have installed.

My guess (am I right?) is that someone modified the plugin for his own
use and then put it into a public repository.

How can I set script/plugin so that it pulls in only generally-released
versions of the plugins?

    — F
This topic is locked and can not be replied to.