Forum: GNU Radio Re: USB2 problems with Fedora/USRP

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Alberto T. (Guest)
on 2009-01-18 23:12
(Received via mailing list)
> Hello
> I've finally assembled the USRP few days ago, after being delayed some months.
> The power-on behaviour
looks as expected: one led blinks at 3 Hz or so.
> The next step is to try out some example, e.g.
> Whatever the test I try, I can see that blinking led is switched of for a couple 
seconds, then it
blinks at lower
> rate, and another led near to it turns on  (don't remember which is D402 and D403).
> On console,
i get this kind of error:
> usb_control_msg failed: error sending control message: Connection timed out
> usrp:
failed to load fpga bitstream
> Traceback (most recent call last):

>     File "./", line 106, in ?
>         main ( )
>     File "./", line 96,
in main
>         ok=run_test (rate, verbose)
>     File "./", line 63, in run_test
usrp_tx=usrp.sink_s(0, tx_interp)
>     File "/usr/local/hamradio/gnuradio/lib/python2.5/site-packages/gnuradio/usrp.
py", line 230, in __init__
>         fpga_filename, firmware_filename)
>     File
line 940, in  sink_s
>         return
> RuntimeError: can't open usrp1
> I'm using the latest svn checked-out source code.
> I'm
almost convinced that the problem is in the USB2 driver used by gnuradio
to control the USRP (ehci-hcd?).
> I have 2
> 1. What do you suggest to use to investigate and troubleshoot such USB2 problem on 
Fedora 9?
> 2. What
does the second led turning on mean?
> t.i.a. for help.
> Alberto

==== On Thu, 2009-01-15 at 13:57 -0800, Johnathan
Corgan wrote:
>In my experience, a successful FX2 load followed by a failed FPGA load
> is often due to poor USB
physical integrity, such as a cable, connector,
> or hub.  I know it sounds formulaic, but for whatever reason, I've
encountered this with the USRP on multiple occasions, where replacing
> the cable with a different one, ensuring that
has the 2.0 compliance
> logo on it, fixes it.  YMMV, of course.
> (Even more often it is due to not having a 2.0
controller, but you've
> ruled that out already.)
> -Johnathan


Well, well, Johnathan, you were right.
found a solution to the problem - not yet an explanation, which requires
a USB guru to explain (anybody out there...?)

I actually plugged the USB cable to an external hub, which is not even
powered (and not even top-branded...) and the
problem does not show anymore.
Note that, after your suggestion, I have tried all four USB2 sockets
available on the
laptop and *none* worked.
Thus, in this instance, it seems that introducing a hub layer in the
path solves the problem.

Thanks again for help

Attiva Tiscali Voce 8 Mega: telefoni e navighi senza limiti a soli €10
AL MESE FINO AL 30 GIUGNO 2009. Dopo paghi €29,90 al mese. Attiva entro
il 22/01/09!
This topic is locked and can not be replied to.