Forum: GNU Radio Audio_alsa_sink question

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Sebastiaan H. (Guest)
on 2009-01-15 13:53
(Received via mailing list)
Hi

I have a problem with the audio sink.  I'm playing around with the
analysis_filterbank block.  I have a GUI allowing the user to pick a
channel.  That channel then gets connected to an FM demodulator,volume
control and finally an audio sink.  At the start of the app, I
initialise everything and the audio sink works.  As soon as I change a
channel by reconnecting everything, I get this error:

audio_alsa_sink[plughw:0,0]: snd_pcm_hw_params failed: File descriptor
in bad state
terminate called after throwing an instance of 'std::runtime_error'
  what():  check topology failed on audio_alsa_sink(8) using
ninputs=1, noutputs=0
Aborted

Can someone please tell me what might be wrong?

Thanks.

Sebastiaan
Eric B. (Guest)
on 2009-01-15 21:21
(Received via mailing list)
On Thu, Jan 15, 2009 at 01:52:08PM +0200, Sebastiaan H. wrote:
> in bad state
> terminate called after throwing an instance of 'std::runtime_error'
>   what():  check topology failed on audio_alsa_sink(8) using
> ninputs=1, noutputs=0
> Aborted
>
> Can someone please tell me what might be wrong?
>
> Thanks.
> Sebastiaan

That's a bug in the implementation of gr-audio-alsa.
If you look in the code you'll find a couple of FIXMEs.
One of those is the thing you've stumbled on to.

Eric
This topic is locked and can not be replied to.