Forum: Ruby on Rails do_sqlite3 - how to acquire & install latest version?

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
technology (Guest)
on 2009-01-13 20:36
(Received via mailing list)
Apparently the reason I can't use sqlite3 with Mac OS X is a bad
version of do_sqlite3. Could someone please spell out exactly what a
newbie needs to do to grab & reinstall the latest version?

on 2009-01-14 05:48
(Received via mailing list)
Download the source from rubyforge:

Extract it and then cd into the extracted directory and run:

ruby setup.rb

Hope this helps.

technology (Guest)
on 2009-01-14 23:38
(Received via mailing list)
Perfect! Thanks very much.

on 2009-01-14 23:41
(Received via mailing list)
Glad it worked. I was stuck in the same predicament a few weeks back
and after going around in circles hit upon the solution.

technology (Guest)
on 2009-01-15 00:11
(Received via mailing list)
I replied too soon, I still get the same error:

MissingSourceFile in HomeController#index

no such file to load -- sqlite3
on 2009-01-15 01:48
(Received via mailing list)
Hmmm. Weird. Do you have the sqlite3 gem installed?

sudo gem install sqlite3-ruby

Sheldon F.
technology (Guest)
on 2009-01-15 18:11
(Received via mailing list)
Yes, and I reinstalled it as you suggested, but still no luck :( Maybe
I'll just switch to mysql for the time being...

bash-3.2$ sudo gem install sqlite3-ruby
Building native extensions.  This could take a while...
Successfully installed sqlite3-ruby-1.2.4
1 gem installed
Installing ri documentation for sqlite3-ruby-1.2.4...
Installing RDoc documentation for sqlite3-ruby-1.2.4...
technology (Guest)
on 2009-01-15 19:00
(Received via mailing list)
Looks like the problem has gone away. I restarted the web server and
it seems to now work fine. Go figure...

Thanks very much for your help.
This topic is locked and can not be replied to.