Forum: Ruby gemness--expected?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Roger P. (Guest)
on 2009-01-11 07:04
(Received via mailing list)
C:\dev\ruby_backtracer>gem install newgem
ERROR:  Error installing newgem:
        newgem requires rubigen (>= 1.5.1, runtime)

C:\dev\ruby_backtracer>gem install rubigen
Successfully installed rubigen-1.5.1
1 gem installed
Installing ri documentation for rubigen-1.5.1...
Installing RDoc documentation for rubigen-1.5.1...

C:\dev\ruby_backtracer>gem install newgem
PostInstall.txt
Successfully installed newgem-1.2.3
1 gem installed
Installing ri documentation for newgem-1.2.3...
Installing RDoc documentation for newgem-1.2.3...

C:\dev\ruby_backtracer>gem -v
1.3.1

expected??
-=r
Daniel B. (Guest)
on 2009-01-11 07:59
(Received via mailing list)
On Jan 10, 10:02 pm, Roger P. <removed_email_address@domain.invalid>
wrote:
> C:\dev\ruby_backtracer>gem install newgem
> PostInstall.txt
> Successfully installed newgem-1.2.3
> 1 gem installed
> Installing ri documentation for newgem-1.2.3...
> Installing RDoc documentation for newgem-1.2.3...
>
> C:\dev\ruby_backtracer>gem -v
> 1.3.1

I must be missing something? What is it that surprises you here?

Regards,

Dan
Rooger Pack (Guest)
on 2009-01-12 20:45
(Received via mailing list)
Apparently newgem has a dependency on rubigen.
I'd expect that
gem install newgem
would auto-install its dependencies, then it.

Thanks!
-=r

C:\dev\ruby_backtracer>gem install newgem
ERROR:  Error installing newgem:
        newgem requires rubigen (>= 1.5.1, runtime)

C:\dev\ruby_backtracer>gem install rubigen
Successfully installed rubigen-1.5.1

C:\dev\ruby_backtracer>gem install newgem
Successfully installed newgem-1.2.3
Daniel B. (Guest)
on 2009-01-13 05:48
(Received via mailing list)
Rooger Pack wrote:
>         newgem requires rubigen (>= 1.5.1, runtime)
>
> C:\dev\ruby_backtracer>gem install rubigen
> Successfully installed rubigen-1.5.1
>
> C:\dev\ruby_backtracer>gem install newgem
> Successfully installed newgem-1.2.3

There is something wrong with this gem. On OS X it installs fine, but I
get a similar error on Vista.

I downloaded the source, but I don't see a gemspec. My suggestion is to
report this to Dr. Nic.

Regards,

Dan
This topic is locked and can not be replied to.