Forum: GNU Radio usrp_wfm_rcv.py and audio underrun aUaUaU

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Mikael J. (Guest)
on 2009-01-09 11:00
(Received via mailing list)
I am having a problem with audio underruns when running usrp_wfm_rcv.py
I constantly get audio underruns. I have tried the "-O plughw:0,0"
option
suggested on this or some other list to overcome this problem, but it
does
not help.
When I reduce usrp_decim from 200 to about 184 the underruns go away,
this I
guess indicates that the issue is not related to the USRP or the USB
interface as this will mean that more data is sent to the host.

The host is a powerful Pentium 2.4(running below 100% cpu load),
platform is
Fedora 10/GNURadio 3.1.3.

Could somebody please give me a hint on how to debug this issue further.

Thanks in advance
/Mikael
Johnathan C. (Guest)
on 2009-01-09 17:20
(Received via mailing list)
On Fri, Jan 9, 2009 at 12:59 AM, Mikael J.
<removed_email_address@domain.invalid> wrote:

> I am having a problem with audio underruns when running usrp_wfm_rcv.py
> I constantly get audio underruns.

> Could somebody please give me a hint on how to debug this issue further.

Edit the file /etc/gnuradio/conf.d/gr-audio-alsa.conf, and change the
line

verbose=false
 to
verbose=true

Re-run your application and post the screen output here.

-Johnathan
Mikael J. (Guest)
on 2009-01-12 09:36
(Received via mailing list)
Jonathan
Thank you for the response.
Below is a print-out with the verbose flag set to true.

Regards
/Mikael

[mikael@gandalf usrp]$ ./usrp_wfm_rcv.py -f 97600000 -V 100 -O
"plughw:0,0"
adc_rate: 64000000
Using RX d'board A: Basic Rx
usrp_rate: 320000
>>> gr_fir_ccf: using SSE
>>> gr_fir_fff: using SSE
audio_rate: 32000, options: plughw:0,0
PCM name: plughw:0,0
Access types:
    MMAP_INTERLEAVED     YES
    MMAP_NONINTERLEAVED  YES
    MMAP_COMPLEX         YES
    RW_INTERLEAVED       YES
    RW_NONINTERLEAVED    YES
Formats:
    S8                   YES
    U8                   YES
    S16_LE               YES
    S16_BE               YES
    U16_LE               YES
    U16_BE               YES
    S24_LE               YES
    S24_BE               YES
    U24_LE               YES
    U24_BE               YES
    S32_LE               YES
    S32_BE               YES
    U32_LE               YES
    U32_BE               YES
    FLOAT_LE             YES
    FLOAT_BE             YES
    FLOAT64_LE           YES
    FLOAT64_BE           YES
    MU_LAW               YES
    A_LAW                YES
    IMA_ADPCM            YES
    S24_3LE              YES
    S24_3BE              YES
    U24_3LE              YES
    U24_3BE              YES
    S20_3LE              YES
    S20_3BE              YES
    U20_3LE              YES
    U20_3BE              YES
    S18_3LE              YES
    S18_3BE              YES
    U18_3LE              YES
    U18_3BE              YES
Number of channels
    min channels: 1
    max channels: 10000
    1 channels    YES
    2 channels    YES
    3 channels    YES
    4 channels    YES
    5 channels    YES
    6 channels    YES
    7 channels    YES
    8 channels    YES
    9 channels    YES
    10 channels    YES
    11 channels    YES
    12 channels    YES
    13 channels    YES
    14 channels    YES
    15 channels    YES
    16 channels    YES
Sample Rates:
    min rate:    4000 (dir = 0)
    max rate:      -1 (dir = -1)
      8000  YES
     16000  YES
     22050  YES
     32000  YES
     44100  YES
     48000  YES
     96000  YES
    192000  YES
audio_alsa_sink[plughw:0,0]: using S32_LE

** (python:27664): WARNING **: IPP request failed with status 1030

** (python:27664): WARNING **: IPP request failed with status 1030
FYI: No Powermate or Contour Knob found
baseband_freq: 0, dxc_freq: 30400000.0, residual_freq:
-0.00596046447754,
inverted: 0)
baseband_freq: 0, dxc_freq: 30400000.0, residual_freq:
-0.00596046447754,
inverted: 0)
audio_alsa_sink[plughw:0,0]: sample resolution = 32 bits
aUaUaUaUaUaUaUaUaUaUaUaUaUaUaUaUaUaUaUaUaUaUaUaUaUaUaUaUaUaUaUaUaUaUaUaUaUaUaU^C
[mikael@gandalf usrp]$


2009/1/9 Johnathan C. <removed_email_address@domain.invalid>
Johnathan C. (Guest)
on 2009-01-12 21:21
(Received via mailing list)
On Sun, Jan 11, 2009 at 11:35 PM, Mikael J.
<removed_email_address@domain.invalid> wrote:

> Below is a print-out with the verbose flag set to true.

It appears that your audio system is working correctly.

I've discovered I get something similar now on one of my test machines
that uses Ubuntu 8.10 and an the nvidia graphics driver.  Apparently,
there is an odd interaction with OpenGL that raises CPU usage to 100%,
which goes away when I turn off GL support in GNU Radio.  Sound
anything like what you're seeing?

-Johnathan
Mikael J. (Guest)
on 2009-01-12 21:22
(Received via mailing list)
In my case CPU usage is below 100%. But I can try to disable OpenGL
anyway,
how can I do that?
Regards
/Mikael

2009/1/12 Johnathan C. <removed_email_address@domain.invalid>
Johnathan C. (Guest)
on 2009-01-12 21:27
(Received via mailing list)
On Mon, Jan 12, 2009 at 11:19 AM, Mikael J.
<removed_email_address@domain.invalid> wrote:

> In my case CPU usage is below 100%. But I can try to disable OpenGL anyway,
> how can I do that?

In /etc/gnuradio/conf.d/gr-wxgui.conf, set the 'style' parameter to
'nongl'.

-Johnathan
Mikael J. (Guest)
on 2009-01-13 09:28
(Received via mailing list)
Thanks
But it made no difference...
/Mikael

2009/1/12 Johnathan C. <removed_email_address@domain.invalid>
Mikael J. (Guest)
on 2009-01-13 13:39
(Received via mailing list)
Any other ideas, suggestions?
Thanks
/Mikael

2009/1/13 Mikael J. <removed_email_address@domain.invalid>
Firas A. (Guest)
on 2009-01-13 14:02
(Received via mailing list)
Hi,

Try :

 usrp_wfm_rcv_nogui.py

if it is working with no aUaUaU, then you have CPU utilization problem.
If not, you have to check if your sound card can accept the required
32KHz audio stream.

Regards,

Firas
Mikael J. (Guest)
on 2009-01-13 14:46
(Received via mailing list)
Thanks for the response

I have the same problem with usrp_wfm_rcv_nogui.py....

Regards
 Mikael


2009/1/13 Firas A. <removed_email_address@domain.invalid>
This topic is locked and can not be replied to.