Forum: Ruby on Rails gem update problem

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Konstantin (Guest)
on 2009-01-09 08:37
(Received via mailing list)

I cannot force a new application to run, it cannot update gems to the
required version. Could you suggest a solution?

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 7.10
Release:        7.10
Codename:       gutsy
$ ruby -v
ruby 1.8.6 (2007-06-07 patchlevel 36) [i486-linux]
$ gem -v

$ sudo gem install rubygems-update
Successfully installed rubygems-update-1.3.1
1 gem installed
$ sudo gem update --system
Updating RubyGems
Nothing to update
$ script/console
Rails requires RubyGems >= 1.3.1 (you have 1.1.0). Please `gem update
--system` and try again.
MaD (Guest)
on 2009-01-09 10:29
(Received via mailing list)
after installing rubygems-update, just run
  sudo update_rubygems
Konstantin (Guest)
on 2009-01-09 14:40
(Received via mailing list)
No success :(
$ sudo update_rubygems
sudo: update_rubygems: command not found
$ sudo update-rubygems
sudo: update-rubygems: command not found
MaD (Guest)
on 2009-01-09 14:55
(Received via mailing list)
well, that's odd.
  gem list
should show you
  rubygems-update (1.3.1)
with that there should be the command
available. if not check your gem-directory which can be found by
  gem environment

for me it is "/usr/lib/ruby/gems/1.8/gems/rubygems-update-1.3.1/bin/
Konstantin (Guest)
on 2009-01-09 15:09
(Received via mailing list)
Ah, I guess the problem is in the paths!
I have changed the standard "gem" command to work by default with
Passenger. So, I guess, I should update the Passenger now?

Here is an output of your commands:

$ gem list -l
rubygems-update (1.3.1)
$ gem environment
RubyGems Environment:
  - RUBY VERSION: 1.8.6 (2008-08-08 patchlevel 286) [i686-linux]
  - INSTALLATION DIRECTORY: /opt/ruby-enterprise-1.8.6-20080810/lib/
  - RUBY EXECUTABLE: /opt/ruby-enterprise-1.8.6-20080810/bin/ruby
  - EXECUTABLE DIRECTORY: /opt/ruby-enterprise-1.8.6-20080810/bin
    - ruby
    - x86-linux
     - /opt/ruby-enterprise-1.8.6-20080810/lib/ruby/gems/1.8
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
     - :sources => ["", "http://"]
MaD (Guest)
on 2009-01-09 15:57
(Received via mailing list)
>   - GEM PATHS:
>      - /opt/ruby-enterprise-1.8.6-20080810/lib/ruby/gems/1.8
you should find the rubygems-update gem there. just go in, locate the
bin-directory and start update_rubygems from there.

still, to save yourself some trouble. look into your path-variables
and make sure everything is working correctly. otherwise you'll be
back here very soon with an other issue.
Sazima (Guest)
on 2009-01-09 15:59
(Received via mailing list)
Exactly, check your paths, or link the standard ruby, gem and rails
commands to the desired version...

Cheers, Sazima
Konstantin (Guest)
on 2009-01-09 19:50
(Received via mailing list)
It's very strange, but I still cannot force the update_rubygems to run
I have tried the full path, but failed:

$ sudo /opt/ruby-enterprise-1.8.6-20080810/lib/ruby/gems/1.8/gems/
Error: Cannot find RubyGems Update Path!
RubyGems has already been updated.
The rubygems-update gem may now be uninstalled.
E.g.    gem uninstall rubygems-update

And I have found a similar problem here:
But unfortunately no new solution....
Mark Reginald J. (Guest)
on 2009-01-09 22:38
(Received via mailing list)
Have you tried downloading the rubygems 1.3.1 source
from , unpacking,
then running "ruby setup.rb" as root in that directory?

Rails Wheels - Find Plugins, List & Sell Plugins -
This topic is locked and can not be replied to.