Forum: Ruby on Rails restful_authentication installation setup problem

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
ih (Guest)
on 2009-01-07 01:54
(Received via mailing list)
I'm new to rails and trying to get restful_authentication working, but
I am getting errors when I try to create a user or login.  I followed
the instructions at the github repository and everything generated
fine and http://localhost:3000/login loads correctly, but when I click
the log in button I get the error:

NameError in SessionsController#create

uninitialized constant User::Authentication

RAILS_ROOT: /home/irvin/code/rails/todo
Application Trace | Framework Trace | Full Trace

/usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/
dependencies.rb:102:in `const_missing'
app/models/user.rb:4
lib/authenticated_system.rb:138:in `logout_keeping_session!'
app/controllers/sessions_controller.rb:10:in `create'


Also when I go to http://localhost:3000/signup I get the following:

 NameError in UsersController#new
uninitialized constant User::Authentication

RAILS_ROOT: /home/irvin/code/rails/todo
Application Trace | Framework Trace | Full Trace

/usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/
dependencies.rb:102:in `const_missing'
app/models/user.rb:4
app/controllers/users_controller.rb:5:in `new'

I am using the following environment:
Ruby version  1.8.7 (i486-linux)
RubyGems version  1.3.1
Rails version  2.2.2
Active Record version  2.2.2
Action Pack version  2.2.2
Active Resource version  2.2.2
Action Mailer version  2.2.2
Active Support version  2.2.2
Application root  /home/irvin/code/rails/todo
Environment  development
Database adapter  sqlite3
Database schema version  20090106210012

Thanks for any help!
ih (Guest)
on 2009-01-07 16:23
(Received via mailing list)
I have the restful_authentication working now, but I did not change
any code.  I installed the app for the restful_authentication tutorial
at http://www.railsforum.com/viewtopic.php?id=14216 and although I
could not get that app working when I tried the other apps I had
restful_authentication installed in they were now working.  I guess
this means my default environment was not setup correctly and when I
installed the tutorial app it installed whatever I needed to get
things working (perhaps the ruby-openid gem).  Does anyone know if the
ruby-openid gem is required to run basic restful_authentication; I did
not see it as a prerequisite in the documentation?
This topic is locked and can not be replied to.