Forum: GNU Radio Problem with inband USRP

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Marc Petit-Huguenin (Guest)
on 2009-01-06 21:08
(Received via mailing list)
Hi,

When running test_usrp_inband_rx, it gets stuck because it does not
receive any data.  Is there a problem with the code in the trunk?
(revision #10191).  The USRP is working fine with the legacy code
(e.g. usrp_rx_cfile).  Here's the output of the program (with the
verbose flag set in usrp_server):

[USRP_SERVER] Initializing...
[TEST_USRP_INBAND_RX] Opening the USRP
[TEST_USRP_INBAND_RX] Requesting RX channel allocation
[USRP_SERVER] Checking chan: 0 owner () size 2
[USRP_SERVER] Assigning channel: 0 to rx0
[TEST_USRP_INBAND_RX] Receiving...
[USRP_SERVER] Sending read request down to start recv


Kernel: 2.6.26 for amd64 (tested also with i386)
libusb-0.1: 0.1.12
libc6: 2.7
libstdc++6: 4.3.2


Thanks for your help.

--
Marc Petit-Huguenin
Home: removed_email_address@domain.invalid
Work: removed_email_address@domain.invalid
Marc Petit-Huguenin (Guest)
on 2009-01-07 19:19
(Received via mailing list)
Marc Petit-Huguenin wrote:
> [TEST_USRP_INBAND_RX] Requesting RX channel allocation
> [USRP_SERVER] Checking chan: 0 owner () size 2
> [USRP_SERVER] Assigning channel: 0 to rx0
> [TEST_USRP_INBAND_RX] Receiving...
> [USRP_SERVER] Sending read request down to start recv
>
>
> Kernel: 2.6.26 for amd64 (tested also with i386)
> libusb-0.1: 0.1.12
> libc6: 2.7
> libstdc++6: 4.3.2

The problem seems to be in usrp_rx.cc, line 123:

  d_urx =
    boost::any_cast<usrp_standard_rx *>(pmt_any_ref(pmt_nth(1, data)));

This code throws the following exception:

exception: boost::bad_any_cast: failed conversion using boost::any_cast

I tried with boost 1.35 and 1.37, with the same result.

Can somebody help?

Thanks.

--
Marc Petit-Huguenin
Home: removed_email_address@domain.invalid
Work: removed_email_address@domain.invalid
Stefan Bruens (Guest)
on 2009-01-12 02:57
(Received via mailing list)
_______________________________________________
Discuss-gnuradio mailing list
removed_email_address@domain.invalid
http://lists.gnu.org/mailman/listinfo/discuss-gnuradio
This topic is locked and can not be replied to.