Forum: Ruby rmagick error on install

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Anmol A. (Guest)
on 2008-12-29 17:08
i have been trying to install rmagick but have been unsuccessful.People
on Rmagick forum told me that the error is a ruby gem error, please help
.

When I typed the command "sudo gem install Rmagick" , I got the
following error::

/usr/local/lib/site_ruby/1.8/rubygems.rb:274:in `initialize': wrong
number of arguments (1 for 0) (ArgumentError)
from /usr/local/lib/site_ruby/1.8/rubygems.rb:274:in `new'
from /usr/local/lib/site_ruby/1.8/rubygems.rb:274:in `configuration'
from /usr/local/lib/site_ruby/1.8/rubygems.rb:520:in `path'
from /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:66:in
`installed_spec_directories'
from /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:56:in
`from_installed_gems'
from /usr/local/lib/site_ruby/1.8/rubygems.rb:736:in `source_index'
from /usr/local/lib/site_ruby/1.8/rubygems/gem_path_searcher.rb:86:in
`init_gemspecs'
from /usr/local/lib/site_ruby/1.8/rubygems/gem_path_searcher.rb:21:in
`initialize'
... 6 levels...
from /usr/local/lib/site_ruby/1.8/rubygems/gem_runner.rb:8:in `require'
from /usr/local/lib/site_ruby/1.8/rubygems/gem_runner.rb:8
from /usr/bin/gem:10:in `require'
from /usr/bin/gem:10

Please help!!!
Thanks in advance.
This topic is locked and can not be replied to.