Forum: Rails deployment cap deploy:restart error to do with 'no passwd entry for app

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Mike P. (Guest)
on 2008-12-24 08:24
After upgrading to capistrano 2.0 I get this error:

 executing `deploy:restart'
  * executing "sudo -p 'sudo password: ' -u app
/var/apps/mobile/current/script/process/reaper"
    servers: ["r1.h1.XXX.com"]
    [r1.h1.XXX.com] executing command
*** [err :: r1.h1.XXX.com] sudo: no passwd entry for app!
*** [err :: r1.h1.XXX.com]
    command finished
command "sudo -p 'sudo password: ' -u app
/var/apps/mobile/current/script/process/reaper" failed on r1.h1.XXX.com
-----

It seems to complain that it will not run a command using sudo because
there is no password. I cant tell if the command requires a non-blank
password or that I have not supplied a password in my cap deploy.rb file
becuase sudo does not require one for me.

Any ideas here on how to tell the internal cap command to be a bit more
chill?

Mike
Hitesh R. (Guest)
on 2009-02-24 15:46
Mike P. wrote:
> After upgrading to capistrano 2.0 I get this error:
>
>  executing `deploy:restart'
>   * executing "sudo -p 'sudo password: ' -u app
> /var/apps/mobile/current/script/process/reaper"
>     servers: ["r1.h1.XXX.com"]
>     [r1.h1.XXX.com] executing command
> *** [err :: r1.h1.XXX.com] sudo: no passwd entry for app!
> *** [err :: r1.h1.XXX.com]
>     command finished
> command "sudo -p 'sudo password: ' -u app
> /var/apps/mobile/current/script/process/reaper" failed on r1.h1.XXX.com
> -----
>
> Mike

may be it will help
http://hiteshrawal.blogspot.com/2009/02/deploy-on-...
This topic is locked and can not be replied to.