Forum: Ruby About qt4-ruby

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Magicloud (Guest)
on 2008-12-17 10:56
(Received via mailing list)
Hi,
    Today I compiled qt4-ruby in my rhel5 box. And have a little test.
Well, when the .rb runs, it says something wrong from qtruby4.so,
libsmokeqt.so.2 does not have symbol of _ZN8QWebView11qt_metacastEPKc.
    I recompiled qt4 with -webkit option, and qt4-ruby. Not helping.
Stefano C. (Guest)
on 2008-12-17 14:23
(Received via mailing list)
Alle Wednesday 17 December 2008, Magicloud ha scritto:
> Hi,
>     Today I compiled qt4-ruby in my rhel5 box. And have a little test.
> Well, when the .rb runs, it says something wrong from qtruby4.so,
> libsmokeqt.so.2 does not have symbol of _ZN8QWebView11qt_metacastEPKc.
>     I recompiled qt4 with -webkit option, and qt4-ruby. Not helping.

It's smoke which doesn't have the symbol, not qt itself, so you'll need
to
recompile smoke, and maybe also qtruby itself too.

Stefano
Magicloud (Guest)
on 2008-12-18 03:56
(Received via mailing list)
Stefano C. wrote:
> recompile smoke, and maybe also qtruby itself too.
>
> Stefano
>
>
>
>
So may I know how to compile smoke? I read smoke/README, and ran the
four commands in it, which gave me a new libsmokeqt.so, which still does
not work.
Stefano C. (Guest)
on 2008-12-18 10:23
(Received via mailing list)
Alle Thursday 18 December 2008, Magicloud ha scritto:
> >
> > Stefano
>
> So may I know how to compile smoke? I read smoke/README, and ran the
> four commands in it, which gave me a new libsmokeqt.so, which still does
> not work.

If you mean the commands:

cd qt
./qtguess.pl
./generate.pl
make

they're not enough. As the README states, they're only to generate the
.cpp
files. What you need is the following:
* go in the top level directory of qtruby
* mkdir build
* cd build
* cmake ..
* make
* sudo make install

This will install qtruby4 in /usr/local (excluding the ruby bindings
themselves, which will be installed in /usr/lib/ruby/site_ruby/1.8 (or
something like this, depending on whether ruby itself is installed). If
you
want to install it somewhere else, replace the cmake .. command with

cmake -DCMAKE_INSTALL_PREFIX=/path/to/install/dir ..

I think this should solve your problem. If you have other questions
about
qtruby, you can post them in the qtruby forum, which you can find at
http://rubyforge.org/projects/korundum, where you'll be more likely to
get an
answer (and a better one, too, since there questions are answered by the
developers themselves).

I hope this helps

Stefano
Magicloud (Guest)
on 2008-12-19 06:06
(Received via mailing list)
Stefano C. wrote:
>>>>     I recompiled qt4 with -webkit option, and qt4-ruby. Not helping.
>
> * mkdir build
> cmake -DCMAKE_INSTALL_PREFIX=/path/to/install/dir ..
>
>
>
I used kdebindings instead of qt4-ruby, everything is fine now.
Thanks.
This topic is locked and can not be replied to.