Forum: Ruby So, uh, where's my gem?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Zeekar (Guest)
on 2008-12-09 04:05
(Received via mailing list)
$ sudo gem install net-sftp
Successfully installed net-sftp-2.0.1
1 gem installed
Installing ri documentation for net-sftp-2.0.1...
Installing RDoc documentation for net-sftp-2.0.1...
$ irb -rubygems -rnet-sftp
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require': no such file to load -- net-sftp (LoadError)
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in `require'
        from /usr/lib/ruby/1.8/irb/init.rb:252:in `load_modules'
        from /usr/lib/ruby/1.8/irb/init.rb:250:in `each'
        from /usr/lib/ruby/1.8/irb/init.rb:250:in `load_modules'
        from /usr/lib/ruby/1.8/irb/init.rb:21:in `setup'
        from /usr/lib/ruby/1.8/irb.rb:54:in `start'
        from /usr/bin/irb:13
$ ri net-sftp
Nothing known about net-sftp

Can anyone help me figure out where my gem wound up?  I've confirmed
that gem and irb and ri are all pointing at the same Ruby install
tree...
Michael G. (Guest)
on 2008-12-09 04:35
(Received via mailing list)
On Mon, Dec 8, 2008 at 8:58 PM, Zeekar <removed_email_address@domain.invalid> 
wrote:
>        from /usr/lib/ruby/1.8/irb/init.rb:252:in `load_modules'
> tree...
Try "require 'net/sftp'"
Ryan D. (Guest)
on 2008-12-10 01:24
(Received via mailing list)
On Dec 8, 2008, at 17:58 , Zeekar wrote:

> $ irb -rubygems -rnet-sftp

-r is hardcoded, it can't be overridden by rubygems. :(

as Michael said, you need -e "require 'net/sftp'; blahblah"
This topic is locked and can not be replied to.