Forum: Rails deployment dev mode ok, prod mode application failed error

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
John G. (Guest)
on 2008-12-02 05:57
I'm new to RoR and trying to deploy a RoR2 app. It works in development
mode, but when I switch to production mode by uncommenting the
ENV['RAILS_ENV'] ||= 'production' line in config/environment.rb, I get
the dreaded "application failed to start properly" unhelp error.
This is on a remote hosting service (, so I don't have
any control over the system. They are using Ruby 1.8.6, Rails 2.2.2, and
apache2 v2.2.10.

Where can I find log info for my app? The log/production.log is empty,
and I can't get to the apache log.  Where else can I look?

What could be the problem? I looked at my .htaccess file, and all is
well (it worked in dev mode). I checked my permissions; all seem OK (and
they worked in dev mode). I have uncommented and modified the
RAILS_GEM_VERSION = '2.2.2' unless defined? RAILS_GEM_VERSION line in
environment.rb as well (this caused me a problem in devl mode, so it was
the first thing I checked in prod mode).

Thanks in advance for any help! Let me know if you want to see

This topic is locked and can not be replied to.