Forum: Ruby on Rails just installed acts_as_state_machine and now cant launch the server

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
lunaclaire (Guest)
on 2008-12-02 05:35
(Received via mailing list)
I just installed AASM and when I run 'ruby script/server' it fails

=> Booting Mongrel (use 'script/server webrick' to force WEBrick)
=> Rails application starting on
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Starting Mongrel listening at
** Starting Rails with development environment...
active_support/dependencies.rb:477:in `const_missing': uninitialized
constant Rails::Initializer::ScottBarron (NameError)

the plugin is installed in the vendor/plugins

I can see the code that declares the modules, so it seems like all
should be cool. I must be missing something... any ideas?

lunaclaire (Guest)
on 2008-12-02 06:37
(Received via mailing list)
never mind... I installed the plugin and in the process got the
previously tagged versions... once I removed them, it all worked fine
This topic is locked and can not be replied to.