Forum: Ruby on Rails I got a problem when I run "gem clean"

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Billy H. (Guest)
on 2008-11-27 16:26
(Received via mailing list)
I bought a new Mac (:P) in these days, and I found that Leopard built-
in rails 1.2.6
But it's rails 2.2.2 right now, so I upgraded Rubygems before I
upgraded rails..
and after I upgraded Rubygems and Rails... I run "gem clean" and got
the error message:

bash-3.2# gem clean
Cleaning up installed gems...
Attempting to uninstall rails-1.2.6
ERROR:  While executing gem ... (Gem::InstallError)
    Unknown gem rails = 1.2.6

hmm.. I don't know how to solve it :(
Could anyone tell me how to solve it? thanks!
Frederick C. (Guest)
on 2008-11-27 16:39
(Received via mailing list)
If I rwmember correctly gem doesn't like removing gems from /System.
My advice would be to not worry about it -rubygems is perfectly happy
with multiple versions of gems

Fred

Sent from my iPhone
This topic is locked and can not be replied to.