Forum: Ruby connection failed error

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Mano a. (Guest)
on 2008-11-27 06:34
I am getting the below error while i try to get response from API. What
should I do to solve this

c:/ruby/lib/ruby/1.8/net/http.rb:564:in `initialize': A connection
attempt failed because the connected party did not properly respond
after a period of time, or established connection failed because
connected host has failed to respond. - connect(2) (Errno::ETIMEDOUT)
  from c:/ruby/lib/ruby/1.8/net/http.rb:564:in `open'
  from c:/ruby/lib/ruby/1.8/net/http.rb:564:in `connect'
  from c:/ruby/lib/ruby/1.8/timeout.rb:48:in `timeout'
  from c:/ruby/lib/ruby/1.8/timeout.rb:76:in `timeout'
  from c:/ruby/lib/ruby/1.8/net/http.rb:564:in `connect'
  from c:/ruby/lib/ruby/1.8/net/http.rb:557:in `do_start'
  from c:/ruby/lib/ruby/1.8/net/http.rb:546:in `start'
  from c:/ruby/lib/ruby/1.8/open-uri.rb:243:in `open_http'
  from c:/ruby/lib/ruby/1.8/open-uri.rb:617:in `buffer_open'
  from c:/ruby/lib/ruby/1.8/open-uri.rb:164:in `open_loop'
  from c:/ruby/lib/ruby/1.8/open-uri.rb:162:in `catch'
  from c:/ruby/lib/ruby/1.8/open-uri.rb:162:in `open_loop'
  from c:/ruby/lib/ruby/1.8/open-uri.rb:132:in `open_uri'
  from c:/ruby/lib/ruby/1.8/open-uri.rb:519:in `open'
  from c:/ruby/lib/ruby/1.8/open-uri.rb:30:in `open'
  from wishpot.rb:19:in `create_urlrequest'
  from wishpot.rb:50
This topic is locked and can not be replied to.