Forum: Ruby on Rails undefined symbol: rb_str_set_len

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Rene C. (Guest)
on 2008-11-24 21:18
I recently downgraded from ruby 1.8.7-p72 to 1.8.6-p287 and now whenever
i try to access the mysqldatabase my rails server (WEBrick) crashes with
the following error:

ruby: symbol lookup error:
/usr/lib/ruby/site_ruby/1.8/i686-linux/mysql.so: undefined symbol:
rb_str_set_len

i first thought it was some sort of linking error or something due to
the downgrade, but i just made another DB from scratch and keep getting
the same result.

Does anyone have an idea of what could be the problem or how to fix it?

-R
Frederick C. (Guest)
on 2008-11-24 21:33
(Received via mailing list)
Probably because your mysql gem has been built against 1.8.6. I'd try
reinstalling the mysql gem.

Fred

Sent from my iPhone

On 24 Nov 2008, at 19:18, Rene Cienfuegos
<removed_email_address@domain.invalid
Rene C. (Guest)
on 2008-11-24 23:31
I tried that too, but didn't work.

The thing that i did right after i posted the message was to remove the
mysql.so in /usr/lib/ruby/site_ruby/1.8/i686-linux/  probably not the
best solution, but it worked.

thanks for the answer

-R
This topic is locked and can not be replied to.