Forum: Ruby on Rails sqlite3 has gone...

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Jej (Guest)
on 2008-11-20 18:48
(Received via mailing list)
Hi all,

I'm struggling since hours with sqlite3. Maybe I'm wrong to post here,
as I feel the problem is not directly related to rails.

After a "gem clean" this morning, mongrel doesn't want to start
anymore:

/Library/Ruby/Site/1.8/rubygems/custom_require.rb:36:in
`gem_original_require': no such file to load -- sqlite3
(MissingSourceFile)

But sqlite3-ruby is well installed under gem (I reinstalled to be
sure, desinstalled, resinstalled, etc) but it can't be loaded: ruby -
rubygems -e "require 'sqlite3'" returns the same error as above. It
loads well if I cd in the sqlite directory.

Here is my gem env:
----------------------------------------
RubyGems Environment:
  - RUBYGEMS VERSION: 1.3.1
  - RUBY VERSION: 1.8.6 (2008-03-03 patchlevel 114) [universal-
darwin9.0]
  - INSTALLATION DIRECTORY: /Library/Ruby/Gems/1.8
  - RUBY EXECUTABLE: /System/Library/Frameworks/Ruby.framework/
Versions/1.8/usr/bin/ruby
  - EXECUTABLE DIRECTORY: /usr/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - universal-darwin-9
  - GEM PATHS:
     - /Library/Ruby/Gems/1.8
     - /Volumes/Maison/.gem/ruby/1.8
     - /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/
ruby/gems/1.8
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
  - REMOTE SOURCES:
     - http://gems.rubyforge.org/
-----------------------------------------------

sqlite is locate here: /Library/Ruby/Gems/1.8/gems/sqlite3-ruby-1.2.4/

I checked the permissions, as mentioned in some forums. I reinstalled
gem and all the gems that where uninstalled by the cleanup.

I'm locked now, I don't know what to look for... Any help welcome.

Thanks,
Jej
Jej (Guest)
on 2008-11-20 20:16
(Received via mailing list)
In case it helps someone, I removed /Library/Ruby and reinstalled
everything. Strange bug...

Jej
Guillaume G. (Guest)
on 2008-11-21 00:58
(Received via mailing list)
Hi all

I've the same problem since this morning.
Trying to uninstall/install didn't do the trick.

The only thing i've done since this yesterday (all work fine
yesterday) is installing updating datamapper.

If anyone has some clues or tips to help me.
Guillaume G. (Guest)
on 2008-11-21 08:42
(Received via mailing list)
Some precision :
launching the same command in the sqlite3 gem work.
I install sqlite3 gem iin my local gem path (~/.gem/ruby/1 .8/gems)
but the result is the same
Karel M. (Guest)
on 2008-11-21 16:44
(Received via mailing list)
Hi,

this is closely related to datamapper and data_objects. It happened to
me yesterday when installed Integrity app and it was *quite* nasty (no
such file... in every Rake task etc).

Solution which has worked for me was from namelessjohn at
#sinatra@freenode [1]:

namelessjon_ # karmi_: sudo rm /path/to/gems/do_sqlite-0.9.7/lib/
sqlite3.dll

Apparently do_sqlite3 gets into the path somehow.

--karmi

[1] http://irclogger.com/sinatra/2008-11-20
Guillaume G. (Guest)
on 2008-11-21 19:52
(Received via mailing list)
It work for me too.

Big thanks for the help.

I think I couldn't find it alone.
Guillaume G. (Guest)
on 2008-11-21 20:02
(Received via mailing list)
After reflecting here what iI think,

In fact when you use rubygems it add all lib folder of each gem to the
load path. So when you require sqlite3 the system try loading all or
the first file the file named sqlite3 exinsting in the load path and
loading a dll file on a system different than windows cause an error.
tilia1 (Guest)
on 2008-12-07 21:07
(Received via mailing list)
I found this at
http://www.rubyhead.com/2008/11/25/no-such-file-to...
for me, it also turned out that

> o_sqlite3 gem that came with Merb caused this problem. The solution is to get rid of 
this gem by running "sudo gem >uninstall do_sqlite3″. However, if you're running 
JRuby and have Merb installed, this won't work.

it also worked to add

> gem 'sqlite3-ruby'

to my environment.rb file from http://www.rubyflow.com/items/1252
tilia1 (Guest)
on 2008-12-07 21:11
(Received via mailing list)
for me two different things worked. adding
  gem 'sqlite3-ruby'
to my environment.rb file. from post at:http://www.rubyflow.com/items/
1252

or remove a problem with a merb gem by

sudo gem uninstall do_sqlite3

from a post at
http://www.rubyhead.com/2008/11/25/no-such-file-to...
This topic is locked and can not be replied to.