Forum: Ruby Newbie install problem

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Terry Carmen (Guest)
on 2008-11-08 22:16
(Received via mailing list)
Could somene take a moment and translate this into English for me?

I'm trying to install NorfelloCMMS, which runs on Ruby/Rails, and the
prerequisites instructions say to run:

gem install rmagick gettext libxml-ruby

Which immediately blows up with the error message below. Any help
would be appreciated.

This is a virgin install of Centos 5.0 with freshly downloaded and
installed ruby (source install from the ruby site).

It seems to be unhappy about "gem_original_require" but I haven't got
a clue where this should be or come from.

Any thoughts?

Thanks!

Terry

/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require': no such file to load -- zlib (LoadError)
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:31:in `require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/package.rb:10
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:31:in `gem_original_require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:31:in `require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/format.rb:9
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:31:in `gem_original_require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:31:in `require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/installer.rb:
11
         ... 11 levels...
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
command_manager.rb:104:in `process_args'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
command_manager.rb:75:in `run'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:
39:in `run'
        from /usr/local/bin/gem:24
Kris W. (Guest)
on 2008-11-08 22:27
rmagick has a ton of prerequisites.
sounds like you need to start by installing zlib

http://www.zlib.net/

> /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
> `gem_original_require': no such file to load -- zlib (LoadError)
Terry Carmen (Guest)
on 2008-11-09 00:45
(Received via mailing list)
On Nov 8, 3:25 pm, Kris W. <removed_email_address@domain.invalid> wrote:
> rmagick has a ton of prerequisites.
> sounds like you need to start by installing zlib
>
> http://www.zlib.net/
>
> > /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
> > `gem_original_require': no such file to load -- zlib (LoadError)
>
> --
> Posted viahttp://www.ruby-forum.com/.


zlib and zlib-devel are installed (from yum). Supposedly ruby has zlib
support built in. Is there anything I need to do to let ruby find
zlib?

Thsnks!

Terry

[root@li48-219 ruby-1.8.7-p72]# gem install  zlib rails redcloth
rmagick gettext libxml-ruby
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require': no such file to load -- zlib (LoadError)
Kris W. (Guest)
on 2008-11-09 03:05
> zlib and zlib-devel are installed (from yum). Supposedly ruby has zlib
> support built in. Is there anything I need to do to let ruby find
> zlib?
>
> Thsnks!
>
> Terry
>
> [root@li48-219 ruby-1.8.7-p72]# gem install  zlib rails redcloth
> rmagick gettext libxml-ruby
> /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
> `gem_original_require': no such file to load -- zlib (LoadError)


Ruby-zlib should be built into Ruby 1.8

you might want to try building ruby-zlib by hand

wget http://www.blue.sky.or.jp/atelier/ruby/ruby-zlib-0...
tar xvzf ruby-zlib-0.6.0.tar.gz
cd ruby-zlib-0.6.0
ruby extconf.rb && make && make install


then, I would try reinstalling Ruby Gems from source.
This topic is locked and can not be replied to.